Skip to content
Laskyr

Plugins · simple-facebook-plugin · data as of 2026-11-04

Is Simple Like Page safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.1)

As of 2026-11-04. 3 issues are on record for older versions; version 2.0.0 or newer fixes all of them that state a fix.

Latest version
2.0.1
Last updated
2026-04-28
Active installs
10,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.2+

Embed Meta™ Page content without slowing down your site or loading third-party scripts before user interaction. — by topdevs.net

What to do

  1. Update to the latest version (2.0.1). Anything older than 2.0.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get simple-facebook-plugin --field=version shows what you run; wp plugin update simple-facebook-plugin updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-63022 · published 2025-12-31

Missing authorization check in Simple Like Page (1.5.3 and older)

Affected
1.5.3 and older
Fixed in
2.0.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in topdevs.net Simple Like Page simple-facebook-plugin allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Simple Like Page: from n/a through <= 1.5.3.

NVD CVE-2025-63022Patchstack advisory

medium 6.4 CVE-2024-3583 · published 2024-05-30

Stored cross-site scripting (XSS) in Simple Like Page (1.5.2 and older)

Affected
1.5.2 and older
Fixed in
1.5.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Simple Like Page Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcode(s) in all versions up to, and including, 1.5.2 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-3583Wordfence advisoryCode change (fix)

medium 5.4 CVE-2023-4888 · published 2023-11-07

Stored cross-site scripting (XSS) in Simple Like Page (1.5.1 and older)

Affected
1.5.1 and older
Fixed in
1.5.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Simple Like Page Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'sfp-page-plugin' shortcode in versions up to, and including, 1.5.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2023-4888Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Simple Like Page vulnerability status badge
<a href="https://laskyr.com/plugins/simple-facebook-plugin"><img src="https://laskyr.com/plugins/simple-facebook-plugin/badge.svg" alt="Simple Like Page vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit