Plugins · simple-event-planner · data as of 2026-11-04
Is Simple Event Planner safe? Known vulnerabilities and latest version
- Latest version
- 1.5.8
- Last updated
- 2026-09-24
- Active installs
- 1,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
A powerful & flexible plugin to create event listing and event calendar on your website in a simple & elegant way. — by PressTigers
What to do
- Update to the latest version (1.5.8). Anything older than 1.5.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get simple-event-planner --field=version shows what you run; wp plugin update simple-event-planner updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.8 CVE-2026-97257 · published 2026-10-05
PHP object injection in Simple Event Planner (1.5.7 and older)
- Affected
- 1.5.7 and older
- Fixed in
- 1.5.8
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Deserialization of Untrusted Data vulnerability in PressTigers Simple Event Planner simple-event-planner allows Object Injection.This issue affects Simple Event Planner: from n/a through 1.5.7.
medium 5.4 CVE-2022-25611 · published 2022-03-25
Stored cross-site scripting (XSS) in Simple Event Planner (1.5.5 and older)
- Affected
- 1.5.5 and older
- Fixed in
- 1.5.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Authenticated Stored Cross-Site Scripting (XSS) in Simple Event Planner plugin <= 1.5.4 allows attackers with contributor or higher user roles to inject the malicious script by using vulnerable parameter &custom[add_seg][].
medium 5.4 CVE-2022-25612 · published 2022-03-25
Cross-site scripting (XSS) in Simple Event Planner (1.5.5 and older)
- Affected
- 1.5.5 and older
- Fixed in
- 1.5.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Multiple Authenticated Persistent Cross-Site Scripting (XSS) vulnerabilities in Simple Event Planner WordPress plugin <= 1.5.4 allows user with author or higher user rights inject the malicious code via vulnerable parameters: &custom[event_organiser], &custom[organiser_email], &custom[organiser_contact].
Recent activity
- 2026-09-24 — latest release on wordpress.org (1.5.8).
- 2026-10-05 — PHP object injection disclosed (CVE-2026-97257), fixed in 1.5.8.
- 2022-03-25 — Stored cross-site scripting (XSS) disclosed (CVE-2022-25611), fixed in 1.5.6.
- 2022-03-25 — Cross-site scripting (XSS) disclosed (CVE-2022-25612), fixed in 1.5.6.
Get an email when Simple Event Planner has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Simple Event Planner (simple-event-planner) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by PressTigers (4 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · PHP object injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/simple-event-planner (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/simple-event-planner"><img src="https://laskyr.com/plugins/simple-event-planner/badge.svg" alt="Simple Event Planner vulnerability status"></a>