Skip to content
Laskyr

Plugins · simple-embed-code · data as of 2026-11-04

Is Code Embed safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.6.4)

As of 2026-11-04. 4 issues are on record for older versions; version 2.5.2 or newer fixes all of them that state a fix.

Latest version
2.6.4
Last updated
2026-08-21
Active installs
10,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Code Embed provides a very easy and efficient way to embed code (JavaScript, CSS and HTML) in your posts and pages. — by David Artiss

What to do

  1. Update to the latest version (2.6.4). Anything older than 2.5.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get simple-embed-code --field=version shows what you run; wp plugin update simple-embed-code updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-2512 · published 2026-03-18

Stored cross-site scripting (XSS) in Code Embed (2.5.1 and older)

Affected
2.5.1 and older
Fixed in
2.5.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Code Embed plugin for WordPress is vulnerable to Stored Cross-Site Scripting via custom field meta values in all versions up to, and including, 2.5.1. This is due to the plugin's sanitization function `sec_check_post_fields()` only running on the `save_post` hook, while WordPress allows custom fields to be added via the `wp_ajax_add_meta` AJAX endpoint without triggering `save_post`. The `ce_filter()` function then outputs these unsanitized meta values directly into page content without escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-2512Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2024-10814 · published 2024-11-09

Server-side request forgery (SSRF) in Code Embed (2.5 and older)

Affected
2.5 and older
Fixed in
2.5.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Code Embed plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.5 via the ce_get_file() function. This makes it possible for authenticated attackers, with contributor-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.

NVD CVE-2024-10814Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2024-8804 · published 2024-10-04

Stored cross-site scripting (XSS) in Code Embed (2.4 and older)

Affected
2.4 and older
Fixed in
2.5.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Code Embed plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's script embed functionality in all versions up to, and including, 2.4 due to insufficient restrictions on who can utilize the functionality. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-8804Wordfence advisoryCode change (fix)

medium 6.5 CVE-2023-49837 · published 2024-03-21

Denial of service in Code Embed (2.3.6 and older)

Affected
2.3.6 and older
Fixed in
2.3.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Uncontrolled Resource Consumption vulnerability in David Artiss Code Embed.This issue affects Code Embed: from n/a through 2.3.6.

NVD CVE-2023-49837Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Code Embed vulnerability status badge
<a href="https://laskyr.com/plugins/simple-embed-code"><img src="https://laskyr.com/plugins/simple-embed-code/badge.svg" alt="Code Embed vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit