Plugins · simple-draft-list · data as of 2026-11-04
Is Draft List safe? Known vulnerabilities and latest version
- Latest version
- 2.6.5
- Last updated
- 2026-08-17
- Active installs
- 40+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
WordPress plugin to manage and promote your unpublished content. — by David Artiss
What to do
- Update to the latest version (2.6.5). Anything older than 2.6.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get simple-draft-list --field=version shows what you run; wp plugin update simple-draft-list updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-66603 · published 2026-08-18
Stored cross-site scripting (XSS) in Draft List (2.6.4 and older)
- Affected
- 2.6.4 and older
- Fixed in
- 2.6.5
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in David Artiss Draft List simple-draft-list allows Stored XSS. This issue affects Draft List: from n/a through 2.6.4.
medium 6.4 CVE-2026-9104 · published 2026-05-22
Stored cross-site scripting (XSS) in Draft List (2.6.3 only)
- Affected
- 2.6.3 only
- Fixed in
- 2.6.4 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Draft List plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Draft Post Title in all versions up to, and including, 2.6.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The unescaped injection path is triggered specifically when the viewing user lacks edit capabilities, meaning payloads embedded in draft post titles via attribute-breakout techniques execute for unauthenticated users and subscribers.
medium 6.4 CVE-2026-4006 · published 2026-03-19
Stored cross-site scripting (XSS) in Draft List (2.6.2 and older)
- Affected
- 2.6.2 and older
- Fixed in
- 2.6.3 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Simple Draft List plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'display_name' post meta (Custom Field) in all versions up to and including 2.6.2. This is due to insufficient input sanitization and output escaping on the author display name when no author URL is present. The plugin accesses `$draft_data->display_name` which, because `display_name` is not a native WP_Post property, triggers WP_Post::__get() and resolves to `get_post_meta($post_id, 'display_name', true)`. When the `user_url` meta field is empty, the `$author` value is assigned to `$author_link` on line 383 without any escaping (unlike line 378 which uses `esc_html()` for the `{{author}}` tag, and line 381 which uses `esc_html()` when a URL is present). This unescaped value is then inserted into the shortcode output via `str_replace()`. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses a page containing the `[drafts]` shortcode with the `{{author+link}}` template tag.
NVD CVE-2026-4006Wordfence advisoryCode change (fix)Plugin source
medium 6.4 CVE-2025-11197 · published 2025-10-11
Stored cross-site scripting (XSS) in Draft List (2.6.1 and older)
- Affected
- 2.6.1 and older
- Fixed in
- 2.6.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Draft List plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'drafts' shortcode in all versions up to, and including, 2.6.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2025-11197Wordfence advisoryCode change (fix)github.com
medium 6.4 CVE-2025-10181 · published 2025-09-20
Stored cross-site scripting (XSS) in Draft List (2.6 and older)
- Affected
- 2.6 and older
- Fixed in
- 2.6.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Draft List plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'drafts' shortcode in all versions up to, and including, 2.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2025-10181Wordfence advisoryCode change (fix)wordpress.orggithub.comPlugin source
Recent activity
- 2026-08-17 — latest release on wordpress.org (2.6.5).
- 2026-08-18 — Stored cross-site scripting (XSS) disclosed (CVE-2026-66603), fixed in 2.6.5.
- 2026-05-22 — Stored cross-site scripting (XSS) disclosed (CVE-2026-9104), fixed in 2.6.4.
- 2026-03-19 — Stored cross-site scripting (XSS) disclosed (CVE-2026-4006), fixed in 2.6.3.
Get an email when Draft List has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Draft List (simple-draft-list) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by David Artiss (3 tracked)
Types found in this plugin: Cross-site scripting (XSS) (5)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/simple-draft-list (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/simple-draft-list"><img src="https://laskyr.com/plugins/simple-draft-list/badge.svg" alt="Draft List vulnerability status"></a>