Plugins · simple-downloads-list · data as of 2026-11-04
Is Simple Downloads List safe? Known vulnerabilities and latest version
- Latest version
- 1.5.0
- Last updated
- 2025-11-02
- Active installs
- 100+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 6.8.12 · PHP 8.2+
Provide a list of downloads for your visitors - quick and easy. With download categories and mobile friendly design. — by Neofix
What to do
- Update to the latest version (1.5.0). Anything older than 1.5.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get simple-downloads-list --field=version shows what you run; wp plugin update simple-downloads-list updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2025-12583 · published 2025-11-08
Missing authorization check in Simple Downloads List (1.4.3 and older)
- Affected
- 1.4.3 and older
- Fixed in
- 1.5.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Simple Downloads List plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'wp_ajax_neofix_sdl_edit' AJAX endpoint along with many others in all versions up to, and including, 1.4.3. This makes it possible for authenticated attackers, with Subscriber-level access and above, to alter many of the plugin's settings/downloads and inject malicious web scripts.
NVD CVE-2025-12583Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2024-13594 · published 2025-01-24
SQL injection in Simple Downloads List (1.4.2 and older)
- Affected
- 1.4.2 and older
- Fixed in
- 1.4.3 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Simple Downloads List plugin for WordPress is vulnerable to SQL Injection via the 'category' attribute of the 'neofix_sdl' shortcode in all versions up to, and including, 1.4.2 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Contributor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
NVD CVE-2024-13594Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2025-11-02 — latest release on wordpress.org (1.5.0).
- 2025-11-08 — Missing authorization check disclosed (CVE-2025-12583), fixed in 1.5.0.
- 2025-01-24 — SQL injection disclosed (CVE-2024-13594), fixed in 1.4.3.
Get an email when Simple Downloads List has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Simple Downloads List (simple-downloads-list) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/simple-downloads-list (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/simple-downloads-list"><img src="https://laskyr.com/plugins/simple-downloads-list/badge.svg" alt="Simple Downloads List vulnerability status"></a>