Plugins · simple-download-counter · data as of 2026-11-04
Is Simple Download Counter safe? Known vulnerabilities and latest version
- Latest version
- 2.3.3
- Last updated
- 2026-08-09
- Active installs
- 2,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6.20+
Simply counts the number of times your files are downloaded. Display download links and counts using shortcodes. — by Jeff Starr
What to do
- Update to the latest version (2.3.3). Anything older than 2.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get simple-download-counter --field=version shows what you run; wp plugin update simple-download-counter updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-4278 · published 2026-03-26
Stored cross-site scripting (XSS) in Simple Download Counter (2.3 and older)
- Affected
- 2.3 and older
- Fixed in
- 2.3.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Simple Download Counter plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'sdc_menu' shortcode in all versions up to, and including, 2.3. This is due to insufficient input sanitization and output escaping on user-supplied shortcode attributes, specifically the 'text' and 'cat' attributes. The 'text' attribute is output directly into HTML content on line 159 without any escaping (e.g., esc_html()). The 'cat' attribute is used unescaped in HTML class attributes on lines 135 and 157 without esc_attr(). This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-4278Wordfence advisoryCode change (fix)Plugin source
medium 4.9 CVE-2025-13677 · published 2025-12-10
Path traversal / file read in Simple Download Counter (2.2.2 and older)
- Affected
- 2.2.2 and older
- Fixed in
- 2.2.3 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Simple Download Counter plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 2.2.2. This is due to insufficient path validation in the `simple_download_counter_parse_path()` function. This makes it possible for authenticated attackers, with Administrator-level access and above, to read the contents of arbitrary files on the server, which may contain sensitive information such as database credentials (wp-config.php) or system files. Please note that the vendor opted to continue to allow remote file downloads from arbitrary locations on the server, however, has disabled this functionality on multi-sites and provided a warning to site owners in the readme.txt when they install the plugin. While not an optimal patch, we have considered this sufficient and recommend users proceed to use the plugin with caution.
NVD CVE-2025-13677Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2025-46240 · published 2025-04-22
Stored cross-site scripting (XSS) in Simple Download Counter (2.2 and older)
- Affected
- 2.2 and older
- Fixed in
- 2.2.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Jeff Starr Simple Download Counter simple-download-counter allows Stored XSS.This issue affects Simple Download Counter: from n/a through <= 2.2.
medium 6.5 CVE-2025-1730 · published 2025-03-01
Path traversal / file read in Simple Download Counter (2.0 and older)
- Affected
- 2.0 and older
- Fixed in
- 2.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Simple Download Counter plugin for WordPress is vulnerable to Arbitrary File Read in all versions up to, and including, 2.0 via the 'simple_download_counter_download_handler'. This makes it possible for authenticated attackers, with Author-level access and above, to extract sensitive data including any local file on the server, such as wp-config.php or /etc/passwd.
NVD CVE-2025-1730Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2023-4838 · published 2023-09-09
Stored cross-site scripting (XSS) in Simple Download Counter (1.6 only)
- Affected
- 1.6 only
- Fixed in
- 1.6.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Simple Download Counter plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcodes in versions up to, and including, 1.6 due to insufficient input sanitization and output escaping on user supplied attributes like 'before' and 'after'. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recent activity
- 2026-08-09 — latest release on wordpress.org (2.3.3).
- 2026-03-26 — Stored cross-site scripting (XSS) disclosed (CVE-2026-4278), fixed in 2.3.1.
- 2025-12-10 — Path traversal / file read disclosed (CVE-2025-13677), fixed in 2.2.3.
- 2025-04-22 — Stored cross-site scripting (XSS) disclosed (CVE-2025-46240), fixed in 2.2.1.
Get an email when Simple Download Counter has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Simple Download Counter (simple-download-counter) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Jeff Starr (7 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3) · Path traversal and file read (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/simple-download-counter (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/simple-download-counter"><img src="https://laskyr.com/plugins/simple-download-counter/badge.svg" alt="Simple Download Counter vulnerability status"></a>