Plugins · simple-divi-shortcode · data as of 2026-11-04
Is Simple Divi Shortcode safe? Known vulnerabilities and latest version
- Latest version
- 1.2.1
- Last updated
- 2026-05-27
- Active installs
- 10,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 5.6+
Insert DIVI Library item inside module content or inside a php template by using a shortcode. — by Fabrice ESQUIROL
What to do
- Update to the latest version (1.2.1). Anything older than 1.2.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get simple-divi-shortcode --field=version shows what you run; wp plugin update simple-divi-shortcode updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-9714 · published 2026-05-29
Stored cross-site scripting (XSS) in Simple Divi Shortcode (1.2 and older)
- Affected
- 1.2 and older
- Fixed in
- 1.2.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Simple Divi Shortcode plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'id' parameter of the [showmodule] shortcode in versions up to, and including, 1.2 This is due to insufficient input sanitization and output escaping in the showmodule_shortcode() function, which concatenates the 'id' shortcode attribute directly into a dynamically constructed shortcode string without applying esc_attr() or any escaping, allowing an attacker to break out of the attribute context and inject arbitrary HTML. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-9714Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-05-27 — latest release on wordpress.org (1.2.1).
- 2026-05-29 — Stored cross-site scripting (XSS) disclosed (CVE-2026-9714), fixed in 1.2.1.
Get an email when Simple Divi Shortcode has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Simple Divi Shortcode (simple-divi-shortcode) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/simple-divi-shortcode (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/simple-divi-shortcode"><img src="https://laskyr.com/plugins/simple-divi-shortcode/badge.svg" alt="Simple Divi Shortcode vulnerability status"></a>