Skip to content
Laskyr

Plugins · simple-custom-login-page · data as of 2026-11-04

Is Simple Custom Login Page safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.4)

As of 2026-11-04. 1 issue is on record for older versions; version 1.0.4 or newer fixes all of them that state a fix.

Latest version
1.0.4
Last updated
2026-04-01
Active installs
60+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.0+

A simple, lightweight plugin to easily customise the admin login page with your brand's logo and colors. — by George Pattichis

What to do

  1. Update to the latest version (1.0.4). Anything older than 1.0.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get simple-custom-login-page --field=version shows what you run; wp plugin update simple-custom-login-page updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2026-10100 · published 2026-06-02

Stored cross-site scripting (XSS) in Simple Custom Login Page (1.0.3 and older)

Affected
1.0.3 and older
Fixed in
1.0.4 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Simple Custom Login Page plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the color settings fields (Page Background, Form Background, Text Color, Link Color) in versions up to and including 1.0.3. This is due to insufficient input sanitization of the color option values (they were registered with register_setting() and stored via the Settings API/update_option() with no sanitize_callback) combined with the values being output into a <style> block on wp-login.php using esc_attr(), which is incorrect for a CSS context (it does not escape ;, {, }, / or *). This makes it possible for authenticated attackers, with administrator-level access and above, to inject arbitrary CSS rules into the login page that are rendered for all unauthenticated visitors, enabling UI-redress and credential-phishing attacks.

NVD CVE-2026-10100Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Simple Custom Login Page vulnerability status badge
<a href="https://laskyr.com/plugins/simple-custom-login-page"><img src="https://laskyr.com/plugins/simple-custom-login-page/badge.svg" alt="Simple Custom Login Page vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit