Skip to content
Laskyr

Plugins · simple-comment-editing · data as of 2026-11-04

Is Simple Comment Editing safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.4.0)

As of 2026-11-04. 2 issues are on record for older versions; version 3.2.0 or newer fixes all of them that state a fix.

Latest version
3.4.0
Last updated
2026-09-11
Active installs
2,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Allow your users to edit their comments for a period of time. Adjust the comment timer and save some admin headaches. — by David Stone

What to do

  1. Update to the latest version (3.4.0). Anything older than 3.2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get simple-comment-editing --field=version shows what you run; wp plugin update simple-comment-editing updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-12681 · published 2025-11-13

Information disclosure in Simple Comment Editing (3.1.0 and older)

Affected
3.1.0 and older
Fixed in
3.2.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Comment Edit Core – Simple Comment Editing plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.1.0 via the 'ajax_get_comment' function. This makes it possible for unauthenticated attackers to extract sensitive data including user IDs, IP addresses, and email addresses.

NVD CVE-2025-12681Wordfence advisoryCode change (fix)Plugin source

medium 4.4 CVE-2025-24703 · published 2025-01-24

Server-side request forgery (SSRF) in Simple Comment Editing (3.0.33 and older)

Affected
3.0.33 and older
Fixed in
3.1.0
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Server-Side Request Forgery (SSRF) vulnerability in Ronald Huereca Comment Edit Core – Simple Comment Editing simple-comment-editing allows Server Side Request Forgery.This issue affects Comment Edit Core – Simple Comment Editing: from n/a through <= 3.0.33.

NVD CVE-2025-24703Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Simple Comment Editing vulnerability status badge
<a href="https://laskyr.com/plugins/simple-comment-editing"><img src="https://laskyr.com/plugins/simple-comment-editing/badge.svg" alt="Simple Comment Editing vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit