Plugins · simple-calendar-for-elementor · data as of 2026-11-04
Is Simple calendar for Elementor safe? Known vulnerabilities and latest version
- Latest version
- 1.6.7
- Last updated
- 2026-01-22
- Active installs
- 500+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 7.2+
Simple calendar plugin for Elementor to show e.g. availability on different days. You can choose between different layouts, colors, create multiple ca … — by Michael
What to do
- Update to the latest version (1.6.7). Anything older than 1.6.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get simple-calendar-for-elementor --field=version shows what you run; wp plugin update simple-calendar-for-elementor updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-1310 · published 2026-01-28
Missing authorization check in Simple calendar for Elementor (1.6.6 and older)
- Affected
- 1.6.6 and older
- Fixed in
- 1.6.7 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Simple calendar for Elementor plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 1.6.6. This is due to missing capability checks on the `miga_ajax_editor_cal_delete` function that is hooked to the `miga_editor_cal_delete` AJAX action with both authenticated and unauthenticated access enabled. This makes it possible for unauthenticated attackers to delete arbitrary calendar entries by sending a request with a valid nonce and the calendar entry ID.
NVD CVE-2026-1310Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2025-47542 · published 2025-05-07
Cross-site request forgery (CSRF) in Simple calendar for Elementor (1.6.5 and older)
- Affected
- 1.6.5 and older
- Fixed in
- 1.6.6
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Michael Simple calendar for Elementor simple-calendar-for-elementor allows Cross Site Request Forgery.This issue affects Simple calendar for Elementor: from n/a through <= 1.6.5.
high 8.8 CVE-2025-46249 · published 2025-04-22
Cross-site request forgery (CSRF) in Simple calendar for Elementor (1.6.4 and older)
- Affected
- 1.6.4 and older
- Fixed in
- 1.6.5
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Michael Simple calendar for Elementor simple-calendar-for-elementor allows Cross Site Request Forgery.This issue affects Simple calendar for Elementor: from n/a through <= 1.6.4.
Recent activity
- 2026-01-22 — latest release on wordpress.org (1.6.7).
- 2026-01-28 — Missing authorization check disclosed (CVE-2026-1310), fixed in 1.6.7.
- 2025-05-07 — Cross-site request forgery (CSRF) disclosed (CVE-2025-47542), fixed in 1.6.6.
- 2025-04-22 — Cross-site request forgery (CSRF) disclosed (CVE-2025-46249), fixed in 1.6.5.
Get an email when Simple calendar for Elementor has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Simple calendar for Elementor (simple-calendar-for-elementor) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site request forgery (CSRF) (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/simple-calendar-for-elementor (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/simple-calendar-for-elementor"><img src="https://laskyr.com/plugins/simple-calendar-for-elementor/badge.svg" alt="Simple calendar for Elementor vulnerability status"></a>