Skip to content
Laskyr

Plugins · simple-blog-card · data as of 2026-11-04

Is Simple Blog Card safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.39)

As of 2026-11-04. 3 issues are on record for older versions; version 2.38 or newer fixes all of them that state a fix.

Latest version
2.39
Last updated
2026-10-30
Active installs
3,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.0+

Get OGP and display blog card. — by Katsushi Kawamori

What to do

  1. Update to the latest version (2.39). Anything older than 2.38 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get simple-blog-card --field=version shows what you run; wp plugin update simple-blog-card updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-32357 · published 2026-03-13

Server-side request forgery (SSRF) in Simple Blog Card (2.37 and older)

Affected
2.37 and older
Fixed in
2.38
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Server-Side Request Forgery (SSRF) vulnerability in Katsushi Kawamori Simple Blog Card simple-blog-card allows Server Side Request Forgery.This issue affects Simple Blog Card: from n/a through <= 2.37.

NVD CVE-2026-32357Patchstack advisory

medium 5.4 CVE-2023-4035 · published 2023-08-30

Stored cross-site scripting (XSS) in Simple Blog Card (older than 1.31)

Affected
older than 1.31
Fixed in
1.31
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Simple Blog Card WordPress plugin before 1.31 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks

NVD CVE-2023-4035WPScan advisory

medium 4.3 CVE-2023-4036 · published 2023-08-30

Security issue in Simple Blog Card (older than 1.32)

Affected
older than 1.32
Fixed in
1.32
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Simple Blog Card WordPress plugin before 1.32 does not ensure that posts to be displayed via a shortcode are public, allowing any authenticated users, such as subscriber, to retrieve arbitrary post title and their content such as draft, private and password protected ones

NVD CVE-2023-4036WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Simple Blog Card vulnerability status badge
<a href="https://laskyr.com/plugins/simple-blog-card"><img src="https://laskyr.com/plugins/simple-blog-card/badge.svg" alt="Simple Blog Card vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit