Skip to content
Laskyr

Plugins · show-posts · data as of 2026-11-04

Is Weaver Show Posts safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.5)

As of 2026-11-04. 3 issues are on record for older versions; version 2.0 or newer fixes all of them that state a fix.

Latest version
2.0.5
Last updated
2026-04-20
Active installs
5,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.2+

Show Posts in a Page via shortcode for any theme — by wpweaver

What to do

  1. Update to the latest version (2.0.5). Anything older than 2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get show-posts --field=version shows what you run; wp plugin update show-posts updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

low 3.3 CVE-2023-3360 · published 2026-09-02

PHP object injection in Weaver Show Posts (older than 1.8.1)

Affected
older than 1.8.1
Fixed in
1.8.1
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by WPScan
Details from the advisory

The Weaver Show Posts WordPress plugin before 1.8.1 unserialises the content of an imported file, which could lead to PHP object injections issues when a high privilege user import a malicious file and a suitable gadget chain is present on the blog.

NVD CVE-2023-3360WPScan advisory

medium 4.4 CVE-2026-2121 · published 2026-03-21

Stored cross-site scripting (XSS) in Weaver Show Posts (1.8.1 and older)

Affected
1.8.1 and older
Fixed in
2.0 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Weaver Show Posts plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'add_class' parameter in all versions up to, and including, 1.8.1. This is due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This primarily affects multisite installations where Administrators do not have the unfiltered_html capability.

NVD CVE-2026-2121Wordfence advisoryyoutu.bePlugin source

medium 5.4 CVE-2023-1404 · published 2023-06-09

Stored cross-site scripting (XSS) in Weaver Show Posts (1.6 and older)

Affected
1.6 and older
Fixed in
1.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Weaver Show Posts Plugin for WordPress is vulnerable to stored Cross-Site Scripting due to insufficient escaping of the profile display name in versions up to, and including, 1.6. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2023-1404Wordfence advisoryWordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Weaver Show Posts vulnerability status badge
<a href="https://laskyr.com/plugins/show-posts"><img src="https://laskyr.com/plugins/show-posts/badge.svg" alt="Weaver Show Posts vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit