Skip to content
Laskyr

Plugins · shortcoder · data as of 2026-11-04

Is Shortcoder safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.6)

As of 2026-11-04. 2 issues are on record for older versions; version 6.5.2 or newer fixes all of them that state a fix.

Latest version
6.6
Last updated
2026-09-14
Active installs
100,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.3+

Create custom "Shortcodes" easily for HTML, JavaScript, CSS code snippets and use the shortcodes within posts, pages & widgets — by vaakash

What to do

  1. Update to the latest version (6.6). Anything older than 6.5.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get shortcoder --field=version shows what you run; wp plugin update shortcoder updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-27074 · published 2026-02-19

Stored cross-site scripting (XSS) in Shortcoder (6.5.1 and older)

Affected
6.5.1 and older
Fixed in
6.5.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in vaakash Shortcoder shortcoder allows Stored XSS.This issue affects Shortcoder: from n/a through <= 6.5.1.

NVD CVE-2026-27074Patchstack advisory

medium 4.3 CVE-2023-49849 · published 2024-12-09

Missing authorization check in Shortcoder (6.3 and older)

Affected
6.3 and older
Fixed in
6.3.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in vaakash Shortcoder shortcoder allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Shortcoder: from n/a through <= 6.3.

NVD CVE-2023-49849Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Shortcoder vulnerability status badge
<a href="https://laskyr.com/plugins/shortcoder"><img src="https://laskyr.com/plugins/shortcoder/badge.svg" alt="Shortcoder vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit