Plugins · shortcode-variables · data as of 2026-11-04
Is Snippet Shortcodes safe? Known vulnerabilities and latest version
- Latest version
- 5.2.1
- Last updated
- 2026-08-14
- Active installs
- 3,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 8.1+
Create a library of custom shortcodes and reusable content, and seamlessly insert them into your posts and pages. — by YeKen
What to do
- Update to the latest version (5.2.1). Anything older than 5.2.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get shortcode-variables --field=version shows what you run; wp plugin update shortcode-variables updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-16758 · published 2026-08-16
Stored cross-site scripting (XSS) in Snippet Shortcodes (5.2.0 and older)
- Affected
- 5.2.0 and older
- Fixed in
- 5.2.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Snippet Shortcodes plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Shortcode Attributes in all versions up to, and including, 5.2.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-16758Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2024-12018 · published 2024-12-12
Missing authorization check in Snippet Shortcodes (4.1.6 and older)
- Affected
- 4.1.6 and older
- Fixed in
- 4.1.7 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Snippet Shortcodes plugin for WordPress is vulnerable to unauthorized Shortcode Deletion due to missing authorization in all versions up to, and including, 4.1.6. Note that a nonce is used as authentication here, but the value is leaked. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete the plugin's Shortcodes.
NVD CVE-2024-12018Wordfence advisoryCode change (fix)wordpress.org
medium 4.3 CVE-2024-4543 · published 2024-07-03
Cross-site request forgery (CSRF) in Snippet Shortcodes (4.1.4 and older)
- Affected
- 4.1.4 and older
- Fixed in
- 4.1.5 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Snippet Shortcodes plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.1.4. This is due to missing or incorrect nonce validation when adding or editing shortcodes. This makes it possible for unauthenticated attackers to modify shortcodes via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Recent activity
- 2026-08-14 — latest release on wordpress.org (5.2.1).
- 2026-08-16 — Stored cross-site scripting (XSS) disclosed (CVE-2026-16758), fixed in 5.2.1.
- 2024-12-12 — Missing authorization check disclosed (CVE-2024-12018), fixed in 4.1.7.
- 2024-07-03 — Cross-site request forgery (CSRF) disclosed (CVE-2024-4543), fixed in 4.1.5.
Get an email when Snippet Shortcodes has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Snippet Shortcodes (shortcode-variables) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1) · Missing authorization (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/shortcode-variables (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/shortcode-variables"><img src="https://laskyr.com/plugins/shortcode-variables/badge.svg" alt="Snippet Shortcodes vulnerability status"></a>