Skip to content
Laskyr

Plugins · shopkeeper-extender · data as of 2026-11-04

Is Shopkeeper Extender safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (11.2)

As of 2026-11-04. 2 issues are on record for older versions; version 7.0 or newer fixes all of them that state a fix.

Latest version
11.2
Last updated
2026-10-26
Active installs
7,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4.1+

Extends the functionality of the Shopkeeper Theme by adding theme specific features. — by Get Bowtied

What to do

  1. Update to the latest version (11.2). Anything older than 7.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get shopkeeper-extender --field=version shows what you run; wp plugin update shopkeeper-extender updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-67544 · published 2025-12-09

Stored cross-site scripting (XSS) in Shopkeeper Extender (7.0 and older)

Affected
7.0 and older
Fixed in
7.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Get Bowtied Shopkeeper Extender shopkeeper-extender allows Stored XSS.This issue affects Shopkeeper Extender: from n/a through < 7.0.

NVD CVE-2025-67544Patchstack advisory

medium 6.4 CVE-2024-2801 · published 2024-04-12

Stored cross-site scripting (XSS) in Shopkeeper Extender (3.6 and older)

Affected
3.6 and older
Fixed in
3.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Shopkeeper Extender plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'image_slide' shortcode in all versions up to, and including, 3.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-2801Wordfence advisoryCode change (fix)wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Shopkeeper Extender vulnerability status badge
<a href="https://laskyr.com/plugins/shopkeeper-extender"><img src="https://laskyr.com/plugins/shopkeeper-extender/badge.svg" alt="Shopkeeper Extender vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit