Plugins · shopengine · data as of 2026-11-04
Is ShopEngine safe? Known vulnerabilities and latest version
- Latest version
- 4.9.8
- Last updated
- 2026-11-02
- Active installs
- 100,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
WooCommerce builder for Elementor & Gutenberg, offering product templates, product sliders, shopping cart, quick view, Woo Wishlist, product filter. — by Roxnor
What to do
- Update to the latest version (4.9.8). Anything older than 4.9.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get shopengine --field=version shows what you run; wp plugin update shopengine updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-75971 · published 2026-08-25
Privilege escalation in ShopEngine (4.9.4 and older)
- Affected
- 4.9.4 and older
- Fixed in
- 4.9.5 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The ShopEngine Elementor WooCommerce Builder Addon – All in One WooCommerce Solution plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 4.9.4. This is due to the `rum_importer()` function being registered on the WordPress core `import_start` action hook with no plugin-owned capability check and no allowlist filtering, causing arbitrary `<wp_option>` name/value pairs parsed from an attacker-supplied WXR import file to be passed directly to `update_option()`. This makes it possible for authenticated attackers, with Shop Manager-level access and above, to write arbitrary WordPress options — most critically setting `users_can_register` to `1` and `default_role` to `administrator` — enabling open self-registration of Administrator accounts and full site takeover. This is exploitable by Shop Manager-level users because WooCommerce grants that role the `import` capability, allowing it to reach the WordPress Importer flow that fires the `import_start` hook on which `rum_importer()` is registered, contrary to the assumption that the hook is restricted to Administrators.
medium 4.3 CVE-2025-12358 · published 2025-12-03
Cross-site request forgery (CSRF) in ShopEngine (4.8.5 and older)
- Affected
- 4.8.5 and older
- Fixed in
- 4.8.6 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The ShopEngine Elementor WooCommerce Builder Addon plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.8.5. This is due to missing nonce validation on the "post_add_to_list" function as well as an incorrect permissions callback in the "Api/init" function. This makes it possible for unauthenticated attackers to add or remove products from a user's wishlist via a forged request granted they can trick a site's user into performing an action such as clicking on a link.
low 2.7 CVE-2025-11888 · published 2025-10-25
Missing authorization check in ShopEngine (4.8.4 and older)
- Affected
- 4.8.4 and older
- Fixed in
- 4.8.5 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The ShopEngine Elementor WooCommerce Builder Addon – All in One WooCommerce Solution plugin for WordPress is vulnerable to unauthorized modification of data due to an insufficient capability check on the post_deactive() function and post_activate() function in all versions up to, and including, 4.8.4. This makes it possible for authenticated attackers, with Editor-level access and above, to activate and deactivate licenses.
low 2.7 CVE-2025-10173 · published 2025-09-26
Missing authorization check in ShopEngine (4.8.3 and older)
- Affected
- 4.8.3 and older
- Fixed in
- 4.8.4 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The ShopEngine Elementor WooCommerce Builder Addon – All in One WooCommerce Solution plugin for WordPress is vulnerable to unauthorized access due to an incorrect capability check on the post_save() function in all versions up to, and including, 4.8.3. This makes it possible for authenticated attackers, with Editor-level access and above, to update the plugin's settings.
high 8.8 CVE-2022-45371 · published 2023-05-25
Cross-site request forgery (CSRF) in ShopEngine (4.1.1 and older)
- Affected
- 4.1.1 and older
- Fixed in
- 4.2.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Wpmet ShopEngine plugin <= 4.1.1 versions.
Recent activity
- 2026-11-02 — latest release on wordpress.org (4.9.8).
- 2026-08-25 — Privilege escalation disclosed (CVE-2026-75971), fixed in 4.9.5.
- 2025-12-03 — Cross-site request forgery (CSRF) disclosed (CVE-2025-12358), fixed in 4.8.6.
- 2025-10-25 — Missing authorization check disclosed (CVE-2025-11888), fixed in 4.8.5.
Get an email when ShopEngine has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for ShopEngine (shopengine) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Roxnor (10 tracked)
Types found in this plugin: Cross-site request forgery (CSRF) (2) · Missing authorization (2) · Privilege escalation (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/shopengine (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/shopengine"><img src="https://laskyr.com/plugins/shopengine/badge.svg" alt="ShopEngine vulnerability status"></a>