Skip to content
Laskyr

Plugins · shopbuilder · data as of 2026-11-04

Is ShopBuilder safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.4.3)

As of 2026-11-04. 6 issues are on record for older versions; version 3.4.3 or newer fixes all of them that state a fix.

Latest version
3.4.3
Last updated
2026-10-29
Active installs
10,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

WooCommerce builder for Elementor includes 80+ widgets, WooCommerce templates, quick view, compare, wishlist, shop & archive page builder and more. — by RadiusTheme

What to do

  1. Update to the latest version (3.4.3). Anything older than 3.4.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get shopbuilder --field=version shows what you run; wp plugin update shopbuilder updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-54871 · published 2026-10-29

Missing authorization check in ShopBuilder (3.4.2 and older)

Affected
3.4.2 and older
Fixed in
3.4.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Mamunur Rashid ShopBuilder – Elementor WooCommerce Builder Addons shopbuilder allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects ShopBuilder – Elementor WooCommerce Builder Addons: from n/a through 3.4.2.

NVD CVE-2026-54871Patchstack advisory

high 7.1 CVE-2026-95596 · published 2026-10-09

Reflected cross-site scripting (XSS) in ShopBuilder (3.4.1 and older)

Affected
3.4.1 and older
Fixed in
3.4.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Mamunur Rashid ShopBuilder – Elementor WooCommerce Builder Addons shopbuilder allows Reflected XSS.This issue affects ShopBuilder – Elementor WooCommerce Builder Addons: from n/a through 3.4.1.

NVD CVE-2026-95596Patchstack advisory

medium 5.3 CVE-2026-32372 · published 2026-03-13

Information disclosure in ShopBuilder (3.2.4 and older)

Affected
3.2.4 and older
Fixed in
3.2.5
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in RadiusTheme ShopBuilder – Elementor WooCommerce Builder Addons shopbuilder allows Retrieve Embedded Sensitive Data.This issue affects ShopBuilder – Elementor WooCommerce Builder Addons: from n/a through <= 3.2.4.

NVD CVE-2026-32372Patchstack advisory

medium 6.1 CVE-2025-13456 · published 2026-01-02

Reflected cross-site scripting (XSS) in ShopBuilder (older than 3.2.2)

Affected
older than 3.2.2
Fixed in
3.2.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The ShopBuilder WordPress plugin before 3.2.2 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.

NVD CVE-2025-13456WPScan advisory

high 8.8 CVE-2024-37520 · published 2024-07-09

File inclusion in ShopBuilder (2.1.12 and older)

Affected
2.1.12 and older
Fixed in
2.1.13
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in RadiusTheme ShopBuilder – Elementor WooCommerce Builder Addons shopbuilder.This issue affects ShopBuilder – Elementor WooCommerce Builder Addons: from n/a through <= 2.1.12.

NVD CVE-2024-37520Patchstack advisoryPatchstack advisory

medium 5.3 CVE-2024-34812 · published 2024-05-14

Information disclosure in ShopBuilder (2.1.8 and older)

Affected
2.1.8 and older
Fixed in
2.1.9
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Insertion of Sensitive Information Into Sent Data vulnerability in RadiusTheme ShopBuilder – Elementor WooCommerce Builder Addons shopbuilder.This issue affects ShopBuilder – Elementor WooCommerce Builder Addons: from n/a through <= 2.1.8.

NVD CVE-2024-34812Patchstack advisoryPatchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
ShopBuilder vulnerability status badge
<a href="https://laskyr.com/plugins/shopbuilder"><img src="https://laskyr.com/plugins/shopbuilder/badge.svg" alt="ShopBuilder vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit