Plugins · shipment-tracker-for-woocommerce · data as of 2026-11-04
Is Shipment Tracker for Woocommerce safe? Known vulnerabilities and latest version
- Status
- Closed 2026-10-29
- Known issues on record
- 2
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate shipment-tracker-for-woocommerce && wp plugin delete shipment-tracker-for-woocommerce
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 2 record(s) do not state which versions are affected.
medium 6.5 CVE-2026-39540 · published 2026-06-15
Cross-site scripting (XSS) in Shipment Tracker for Woocommerce (1.5.3.2 and older)
- Affected
- 1.5.3.2 and older
- Fixed in
- 1.5.3.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber Cross Site Scripting (XSS) in Shipment Tracker for Woocommerce <= 1.5.3.2 versions.
high 7.1 CVE-2025-24586 · published 2025-04-17
Reflected cross-site scripting (XSS) in Shipment Tracker for Woocommerce (1.4.23 and older)
- Affected
- 1.4.23 and older
- Fixed in
- 1.4.23.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bitsstech Shipment Tracker for Woocommerce shipment-tracker-for-woocommerce allows Reflected XSS.This issue affects Shipment Tracker for Woocommerce: from n/a through <= 1.4.23.
Recent activity
- 2026-10-29 — closed on wordpress.org.
- 2026-06-15 — Cross-site scripting (XSS) disclosed (CVE-2026-39540), fixed in 1.5.3.3.
- 2025-04-17 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-24586), fixed in 1.4.23.1.
Get an email when Shipment Tracker for Woocommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Shipment Tracker for Woocommerce (shipment-tracker-for-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/shipment-tracker-for-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/shipment-tracker-for-woocommerce"><img src="https://laskyr.com/plugins/shipment-tracker-for-woocommerce/badge.svg" alt="Shipment Tracker for Woocommerce vulnerability status"></a>