Plugins · shelf-planner · data as of 2026-11-04
Is Shelf Planner Inventory Management for WooComm… safe? Known vulnerabilities and latest version
- Latest version
- 2.9.0
- Last updated
- 2026-10-09
- Active installs
- 100+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.0+
Professional Inventory Management. Demand Forecasting. Automated Replenishment. All in one powerful tool. — by Shelf Planner
What to do
- Update to the latest version (2.9.0). Anything older than 2.8.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get shelf-planner --field=version shows what you run; wp plugin update shelf-planner updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2025-11891 · published 2025-11-11
Information disclosure in Shelf Planner Inventory Management for WooComm… (2.8.1 and older)
- Affected
- 2.8.1 and older
- Fixed in
- 2.8.2 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Shelf Planner plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.8.1 through publicly exposed log files. This makes it possible for unauthenticated attackers to view potentially sensitive information contained in the exposed log files.
medium 5.3 CVE-2025-11894 · published 2025-11-11
Missing authorization check in Shelf Planner Inventory Management for WooComm… (2.8.1 and older)
- Affected
- 2.8.1 and older
- Fixed in
- 2.8.2 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Shelf Planner plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on several REST API endpoints in all versions up to, and including, 2.8.1. This makes it possible for unauthenticated attackers to modify several of the plugin's settings like the ServerKey and LicenseKey.
Recent activity
- 2026-10-09 — latest release on wordpress.org (2.9.0).
- 2025-11-11 — Information disclosure disclosed (CVE-2025-11891), fixed in 2.8.2.
- 2025-11-11 — Missing authorization check disclosed (CVE-2025-11894), fixed in 2.8.2.
Get an email when Shelf Planner Inventory Management for WooComm… has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Shelf Planner Inventory Management for WooComm… (shelf-planner) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Sensitive data exposure (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/shelf-planner (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/shelf-planner"><img src="https://laskyr.com/plugins/shelf-planner/badge.svg" alt="Shelf Planner Inventory Management for WooComm… vulnerability status"></a>