Skip to content
Laskyr

Plugins · sheets-to-wp-table-live-sync · data as of 2026-11-04

Is FlexTable safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.26.1)

As of 2026-11-04. 3 issues are on record for older versions; version 3.24.1 or newer fixes all of them that state a fix.

Latest version
3.26.1
Last updated
2026-11-03
Active installs
3,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Turn Google Sheets into live WordPress tables. Embed, sync, and customize data instantly with search, filters, and styling - no coding needed. — by WPPOOL

What to do

  1. Update to the latest version (3.26.1). Anything older than 3.24.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get sheets-to-wp-table-live-sync --field=version shows what you run; wp plugin update sheets-to-wp-table-live-sync updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-24582 · published 2026-05-25

Missing authorization check in FlexTable (3.24.0 and older)

Affected
3.24.0 and older
Fixed in
3.24.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WPPOOL FlexTable allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects FlexTable: from n/a through 3.24.0.

NVD CVE-2026-24582Patchstack advisory

medium 5.9 CVE-2024-34375 · published 2024-05-06

Stored cross-site scripting (XSS) in FlexTable (3.7.0 and older)

Affected
3.7.0 and older
Fixed in
3.7.1
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPPOOL Sheets To WP Table Live Sync allows Stored XSS.This issue affects Sheets To WP Table Live Sync: from n/a through 3.7.0.

NVD CVE-2024-34375Patchstack advisory

high 8.8 CVE-2023-26535 · published 2023-11-22

Cross-site request forgery (CSRF) in FlexTable (2.12.15 and older)

Affected
2.12.15 and older
Fixed in
2.13.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in WPPOOL Sheets To WP Table Live Sync plugin <= 2.12.15 versions.

NVD CVE-2023-26535Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
FlexTable vulnerability status badge
<a href="https://laskyr.com/plugins/sheets-to-wp-table-live-sync"><img src="https://laskyr.com/plugins/sheets-to-wp-table-live-sync/badge.svg" alt="FlexTable vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit