Skip to content
Laskyr

Plugins · share-this-image · data as of 2026-11-04

Is Share This Image safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.17)

As of 2026-11-04. 9 issues are on record for older versions; version 2.15 or newer fixes all of them that state a fix.

Latest version
2.17
Last updated
2026-10-08
Active installs
1,000+
Known issues on record
9
Unpatched in latest
0
Tested up to WP
7.1.4

Image sharing plugin for WordPress. Share exactly needed images with fully customizable content. — by ILLID

What to do

  1. Update to the latest version (2.17). Anything older than 2.15 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get share-this-image --field=version shows what you run; wp plugin update share-this-image updates it.

Check your version

Known vulnerabilities

9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-42641 · published 2026-04-29

Server-side request forgery (SSRF) in Share This Image (2.14 and older)

Affected
2.14 and older
Fixed in
2.15
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Server-Side Request Forgery (SSRF) vulnerability in ILLID Share This Image share-this-image allows Server Side Request Forgery.This issue affects Share This Image: from n/a through <= 2.14.

NVD CVE-2026-42641Patchstack advisory

medium 5.3 CVE-2026-39563 · published 2026-04-08

Missing authorization check in Share This Image (2.12 and older)

Affected
2.12 and older
Fixed in
2.13
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in ILLID Share This Image share-this-image allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Share This Image: from n/a through <= 2.12.

NVD CVE-2026-39563Patchstack advisory

medium 5.3 CVE-2026-25010 · published 2026-02-03

Missing authorization check in Share This Image (2.09 and older)

Affected
2.09 and older
Fixed in
2.10
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in ILLID Share This Image share-this-image allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Share This Image: from n/a through <= 2.09.

NVD CVE-2026-25010Patchstack advisory

high 7.1 CVE-2024-47326 · published 2024-10-06

Reflected cross-site scripting (XSS) in Share This Image (2.01 and older)

Affected
2.01 and older
Fixed in
2.02
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ILLID Share This Image share-this-image allows Reflected XSS.This issue affects Share This Image: from n/a through <= 2.01.

NVD CVE-2024-47326Patchstack advisory

medium 6.1 CVE-2024-8761 · published 2024-09-17

Open redirect in Share This Image (2.03 and older)

Affected
2.03 and older
Fixed in
2.04 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Share This Image plugin for WordPress is vulnerable to Open Redirect in all versions up to, and including, 2.03. This is due to insufficient validation on the redirect url supplied via the link parameter. This makes it possible for unauthenticated attackers to redirect users to potentially malicious sites if they can successfully trick them into performing an action.

NVD CVE-2024-8761Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 5.4 CVE-2024-8363 · published 2024-09-05

Stored cross-site scripting (XSS) in Share This Image (2.02 and older)

Affected
2.02 and older
Fixed in
2.03 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Share This Image plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's STI Buttons shortcode in all versions up to, and including, 2.02 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-8363Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 5.4 CVE-2024-8108 · published 2024-08-31

Stored cross-site scripting (XSS) in Share This Image (2.01 and older)

Affected
2.01 and older
Fixed in
2.02 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Share This Image plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'alignment' parameter in all versions up to, and including, 2.01 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-8108Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 4.7 CVE-2024-33930 · published 2024-05-02

Open redirect in Share This Image (1.97 and older)

Affected
1.97 and older
Fixed in
1.98 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

URL Redirection to Untrusted Site ('Open Redirect') vulnerability in ILLID Share This Image.This issue affects Share This Image: from n/a through 1.97.

NVD CVE-2024-33930Patchstack advisory

medium 6.1 CVE-2017-18015 · published 2018-01-02

Cross-site scripting (XSS) in Share This Image (older than 1.04)

Affected
older than 1.04
Fixed in
1.04
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The ILLID Share This Image plugin before 1.04 for WordPress has XSS via the sharer.php url parameter.

NVD CVE-2017-18015wordpress.orgpacketstormsecurity.comwpvulndb.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Share This Image vulnerability status badge
<a href="https://laskyr.com/plugins/share-this-image"><img src="https://laskyr.com/plugins/share-this-image/badge.svg" alt="Share This Image vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit