Skip to content
Laskyr

Plugins · service-booking-manager · data as of 2026-11-04

Is Appointment Booking Plugin for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.5)

As of 2026-11-04. 5 issues are on record for older versions; version 1.4.2 or newer fixes all of them that state a fix.

Latest version
1.4.5
Last updated
2026-10-14
Active installs
200+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.0+

Turn any WordPress site into an online appointment booking system. Real-time calendar, staff scheduling, WooCommerce payments, coupons, and a customer … — by magepeopleteam

What to do

  1. Update to the latest version (1.4.5). Anything older than 1.4.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get service-booking-manager --field=version shows what you run; wp plugin update service-booking-manager updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-66687 · published 2026-08-13

Cross-site scripting (XSS) in Appointment Booking Plugin for WooCommerce (1.3.2 and older)

Affected
1.3.2 and older
Fixed in
1.4.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Customer Cross Site Scripting (XSS) in WpBookingly <= 1.3.2 versions.

NVD CVE-2026-66687Patchstack advisory

medium 4.3 CVE-2026-25444 · published 2026-05-26

Missing authorization check in Appointment Booking Plugin for WooCommerce (1.2.9 and older)

Affected
1.2.9 and older
Fixed in
1.3.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Magepeople inc. WpBookingly allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects WpBookingly: from n/a through 1.2.9.

NVD CVE-2026-25444Patchstack advisory

medium 6.5 CVE-2026-27405 · published 2026-05-20

Missing authorization check in Appointment Booking Plugin for WooCommerce (1.2.9 and older)

Affected
1.2.9 and older
Fixed in
1.3.0
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Magepeople inc. WpBookingly allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects WpBookingly: from n/a through 1.2.9.

NVD CVE-2026-27405Patchstack advisory

high 7.5 CVE-2026-32384 · published 2026-03-13

File inclusion in Appointment Booking Plugin for WooCommerce (1.2.9 and older)

Affected
1.2.9 and older
Fixed in
1.3.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in magepeopleteam WpBookingly service-booking-manager allows PHP Local File Inclusion.This issue affects WpBookingly: from n/a through <= 1.2.9.

NVD CVE-2026-32384Patchstack advisory

critical 9.8 CVE-2025-32607 · published 2025-04-11

PHP object injection in Appointment Booking Plugin for WooCommerce (1.3.0 and older)

Affected
1.3.0 and older
Fixed in
1.4.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in magepeopleteam WpBookingly service-booking-manager allows Object Injection.This issue affects WpBookingly: from n/a through <= 1.3.0.

NVD CVE-2025-32607Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Appointment Booking Plugin for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/service-booking-manager"><img src="https://laskyr.com/plugins/service-booking-manager/badge.svg" alt="Appointment Booking Plugin for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit