Plugins · sertifier-certificates-open-badges · data as of 2026-11-04
Is Sertifier Certificate & Badge Maker for WordPr… safe? Known vulnerabilities and latest version
- Latest version
- 1.21
- Last updated
- 2025-09-11
- Active installs
- 60+
- Known issues on record
- 2
- Unpatched in latest
- 1
- Tested up to WP
- 6.8.12 · PHP 7.0+
Easily create professional certificates and badges for every course or training you offer on WordPress. Give your students an exciting way to showcase … — by sertifier
What to do
- There is no fixed version yet. If you can live without Sertifier Certificate & Badge Maker for WordPr… for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get sertifier-certificates-open-badges --field=version shows what you run; wp plugin update sertifier-certificates-open-badges updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 affects latest 1.21 CVE-2025-53214 · published 2025-11-06
Missing authorization check in Sertifier Certificate & Badge Maker for WordPr… (1.21 and older)
- Affected
- 1.21 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in sertifier Sertifier Certificate & Badge Maker sertifier-certificates-open-badges allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Sertifier Certificate & Badge Maker: from n/a through <= 1.21.
medium 4.3 CVE-2025-7841 · published 2025-08-23
Cross-site request forgery (CSRF) in Sertifier Certificate & Badge Maker for WordPr… (1.19 and older)
- Affected
- 1.19 and older
- Fixed in
- 1.20 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Sertifier Certificate & Badge Maker for WordPress – Tutor LMS plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.19. This is due to missing or incorrect nonce validation on the 'sertifier_settings' page. This makes it possible for unauthenticated attackers to update the plugin's api key via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2025-7841Wordfence advisoryCode change (fix)wordpress.org
Recent activity
- 2025-09-11 — latest release on wordpress.org (1.21).
- 2025-11-06 — Missing authorization check disclosed (CVE-2025-53214), no fix listed yet.
- 2025-08-23 — Cross-site request forgery (CSRF) disclosed (CVE-2025-7841), fixed in 1.20.
Get an email when Sertifier Certificate & Badge Maker for WordPr… has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Sertifier Certificate & Badge Maker for WordPr… (sertifier-certificates-open-badges) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/sertifier-certificates-open-badges (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/sertifier-certificates-open-badges"><img src="https://laskyr.com/plugins/sertifier-certificates-open-badges/badge.svg" alt="Sertifier Certificate & Badge Maker for WordPr… vulnerability status"></a>