Skip to content
Laskyr

Plugins · serbian-transliteration · data as of 2026-11-04

Is Transliterator safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.5.14)

As of 2026-11-04. 2 issues are on record for older versions; version 2.5.14 or newer fixes all of them that state a fix.

Latest version
2.5.14
Last updated
2026-10-28
Active installs
3,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Universal WordPress transliteration for multilingual and non-Latin URLs, permalinks, media, search and SEO-friendly content. — by Ivijan-Stefan Stipic

What to do

  1. Update to the latest version (2.5.14). Anything older than 2.5.14 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get serbian-transliteration --field=version shows what you run; wp plugin update serbian-transliteration updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.3 CVE-2026-39732 · published 2026-10-30

SQL injection in Transliterator (2.5.13 and older)

Affected
2.5.13 and older
Fixed in
2.5.14
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated SQL Injection in Transliterator <= 2.5.13 versions.

NVD CVE-2026-39732Patchstack advisory

high 7.2 CVE-2026-96575 · published 2026-10-03

Stored cross-site scripting (XSS) in Transliterator (2.5.8 and older)

Affected
2.5.8 and older
Fixed in
2.5.9 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Transliterator – Multilingual and Multi-script Text Conversion plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Comment Content via Predictable {rstr_keep} Placeholder in all versions up to, and including, 2.5.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The payload survives WordPress comment save-time sanitization because the tags and attributes used (such as a[title] and code) are permitted by the core comment kses allow-list, and the literal characters comprising the plugin's shortcode markers and placeholder tokens are not stripped.

NVD CVE-2026-96575Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Transliterator vulnerability status badge
<a href="https://laskyr.com/plugins/serbian-transliteration"><img src="https://laskyr.com/plugins/serbian-transliteration/badge.svg" alt="Transliterator vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit