Skip to content
Laskyr

Plugins · sequential-order-numbers-for-woocommerce · data as of 2026-11-04

Is Sequential Order Numbers for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.7)

As of 2026-11-04. 2 issues are on record for older versions; version 3.7 or newer fixes all of them that state a fix.

Latest version
3.7
Last updated
2026-10-23
Active installs
900+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Sequential Order Numbers for WooCommerce – Plugin for change woocommerce orders number. Create your own order number type. — by BeRocket

What to do

  1. Update to the latest version (3.7). Anything older than 3.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get sequential-order-numbers-for-woocommerce --field=version shows what you run; wp plugin update sequential-order-numbers-for-woocommerce updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-104727 · published 2026-10-29

Stored cross-site scripting (XSS) in Sequential Order Numbers for WooCommerce (3.6.5 and older)

Affected
3.6.5 and older
Fixed in
3.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Sequential Order Numbers for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'condition' Post Meta Array Keys in all versions up to, and including, 3.6.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-104727Wordfence advisoryPlugin source

medium 4.3 CVE-2025-32263 · published 2025-04-04

Cross-site request forgery (CSRF) in Sequential Order Numbers for WooCommerce (3.6.2 and older)

Affected
3.6.2 and older
Fixed in
3.6.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in BeRocket Sequential Order Numbers for WooCommerce sequential-order-numbers-for-woocommerce allows Cross Site Request Forgery.This issue affects Sequential Order Numbers for WooCommerce: from n/a through <= 3.6.2.

NVD CVE-2025-32263Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Sequential Order Numbers for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/sequential-order-numbers-for-woocommerce"><img src="https://laskyr.com/plugins/sequential-order-numbers-for-woocommerce/badge.svg" alt="Sequential Order Numbers for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit