Plugins · seo-slider · data as of 2026-11-04
Is SEO Slider safe? Known vulnerabilities and latest version
- Latest version
- 0.0
- Last updated
- 2023-11-02
- Active installs
- 1,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 6.3.14 · PHP 5.6+
Displays a lightweight slider optimized for search engines, accessibility and mobile devices. — by seothemes
What to do
- Update to the latest version (0.0). Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get seo-slider --field=version shows what you run; wp plugin update seo-slider updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 2 record(s) do not state which versions are affected.
medium 6.5 CVE-2025-62097 · published 2025-12-31
Cross-site scripting (XSS) in SEO Slider (1.1.1 and older)
- Affected
- 1.1.1 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Note: the source's version range goes past the newest SEO Slider release on wordpress.org (0.0), so it probably describes a paid edition with its own version numbers, or contains a typo. We do not use it to judge your version.
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in seothemes SEO Slider seo-slider allows DOM-Based XSS.This issue affects SEO Slider: from n/a through <= 1.1.1.
medium 5.4 CVE-2023-5707 · published 2023-11-03
Stored cross-site scripting (XSS) in SEO Slider (1.1.0 and older)
- Affected
- 1.1.0 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Note: the source's version range goes past the newest SEO Slider release on wordpress.org (0.0), so it probably describes a paid edition with its own version numbers, or contains a typo. We do not use it to judge your version.
Details from the advisory
The SEO Slider plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'slider' shortcode and post meta in all versions up to, and including, 1.1.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2023-5707Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2023-11-02 — latest release on wordpress.org (0.0).
- 2025-12-31 — Cross-site scripting (XSS) disclosed (CVE-2025-62097), fix version not stated.
- 2023-11-03 — Stored cross-site scripting (XSS) disclosed (CVE-2023-5707), fix version not stated.
Get an email when SEO Slider has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for SEO Slider (seo-slider) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/seo-slider (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/seo-slider"><img src="https://laskyr.com/plugins/seo-slider/badge.svg" alt="SEO Slider vulnerability status"></a>