Plugins · seo-booster · data as of 2026-11-04
Is SEO Booster safe? Known vulnerabilities and latest version
- Latest version
- 7.5.3
- Last updated
- 2026-10-29
- Active installs
- 800+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
Google Search Console in WordPress: keyword insights, on-page SEO, internal links. AI via WordPress Connectors or SEO Booster Credits. — by cleverplugins
What to do
- Update to the latest version (7.5.3). Anything older than 7.4.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get seo-booster --field=version shows what you run; wp plugin update seo-booster updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-15660 · published 2026-09-19
Missing authorization check in SEO Booster (7.4.7 and older)
- Affected
- 7.4.7 and older
- Fixed in
- 7.4.8 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The SEO Booster plugin for WordPress is vulnerable to Missing Authorization in versions up to, and including, 7.4.7. This is due to a missing capability check on the handle_oauth_callback() function which is hooked to admin_init and processes $_GET['access_token'] and $_GET['google_email'] without verifying the caller's role. This makes it possible for authenticated attackers, with Subscriber-level access and above, to overwrite the seobooster_access_token, seobooster_google_email, and seobooster_gsc_sites options and delete the seobooster_needs_reauth flag by visiting a crafted /wp-admin/ URL, disrupting the Google Search Console integration and injecting attacker-chosen data into site options via the attacker-supplied token that drives an outbound Google API request whose response is stored.
NVD CVE-2026-15660Wordfence advisoryCode change (fix)Plugin source
medium 4.9 CVE-2026-15445 · published 2026-07-16
SQL injection in SEO Booster (7.3.1 and older)
- Affected
- 7.3.1 and older
- Fixed in
- 7.3.2 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The SEO Booster plugin for WordPress is vulnerable to time-based SQL Injection via the 'orderby' parameter in all versions up to, and including, 7.3.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. Although esc_sql() and sanitize_text_field() are applied, neither neutralizes SQL keywords, commas, parentheses, or subquery syntax in an unquoted ORDER BY context, leaving the clause fully attacker-controlled.
NVD CVE-2026-15445Wordfence advisoryCode change (fix)Plugin source
medium 4.9 CVE-2026-15458 · published 2026-07-16
SQL injection in SEO Booster (7.3.1 and older)
- Affected
- 7.3.1 and older
- Fixed in
- 7.3.2 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The SEO Booster plugin for WordPress is vulnerable to generic SQL Injection via the 'sort_field' parameter in all versions up to, and including, 7.3.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
NVD CVE-2026-15458Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2025-68019 · published 2026-01-22
Missing authorization check in SEO Booster (6.1.8 and older)
- Affected
- 6.1.8 and older
- Fixed in
- 7.2 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in cleverplugins SEO Booster seo-booster allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects SEO Booster: from n/a through <= 6.1.8.
high 8.8 CVE-2024-32438 · published 2024-04-15
Cross-site request forgery (CSRF) in SEO Booster (3.8.9 and older)
- Affected
- 3.8.9 and older
- Fixed in
- 3.8.10
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in cleverplugins.Com SEO Booster.This issue affects SEO Booster: from n/a through 3.8.9.
high 7.2 CVE-2021-24747 · published 2021-12-13
SQL injection in SEO Booster (older than 3.8)
- Affected
- older than 3.8
- Fixed in
- 3.8
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- NVD analysis · score by NVD
Details from the advisory
The SEO Booster WordPress plugin before 3.8 allows for authenticated SQL injection via the "fn_my_ajaxified_dataloader_ajax" AJAX request as the $_REQUEST['order'][0]['dir'] parameter is not properly escaped leading to blind and error-based SQL injections.
Recent activity
- 2026-10-29 — latest release on wordpress.org (7.5.3).
- 2026-09-19 — Missing authorization check disclosed (CVE-2026-15660), fixed in 7.4.8.
- 2026-07-16 — SQL injection disclosed (CVE-2026-15445), fixed in 7.3.2.
- 2026-07-16 — SQL injection disclosed (CVE-2026-15458), fixed in 7.3.2.
Get an email when SEO Booster has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for SEO Booster (seo-booster) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: SQL injection (3) · Missing authorization (2) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/seo-booster (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/seo-booster"><img src="https://laskyr.com/plugins/seo-booster/badge.svg" alt="SEO Booster vulnerability status"></a>