Plugins · seo-automated-link-building · data as of 2026-11-04
Is Internal Links Manager safe? Known vulnerabilities and latest version
- Latest version
- 3.2.0
- Last updated
- 2026-10-20
- Active installs
- 10,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Automated internal linking made easy. Optimize your SEO performance, strengthen your link juice, and improve user experience automatically. — by webraketen
What to do
- Update to the latest version (3.2.0). Anything older than 3.0.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get seo-automated-link-building --field=version shows what you run; wp plugin update seo-automated-link-building updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-57345 · published 2026-07-02
Cross-site scripting (XSS) in Internal Links Manager (3.0.3 and older)
- Affected
- 3.0.3 and older
- Fixed in
- 3.0.4
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Internal Links Manager <= 3.0.3 versions.
medium 4.3 CVE-2025-9949 · published 2025-09-20
Cross-site request forgery (CSRF) in Internal Links Manager (3.0.1 and older)
- Affected
- 3.0.1 and older
- Fixed in
- 3.0.2 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Internal Links Manager plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.0.1. This is due to missing or incorrect nonce validation on the link deletion functionality in the process_bulk_action() function. This makes it possible for unauthenticated attackers to delete SEO links via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2025-9949Wordfence advisoryCode change (fix)wordpress.org
medium 4.3 CVE-2025-24679 · published 2025-01-24
Missing authorization check in Internal Links Manager (2.5.2 and older)
- Affected
- 2.5.2 and older
- Fixed in
- 2.5.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in webraketen Internal Links Manager seo-automated-link-building allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Internal Links Manager: from n/a through <= 2.5.2.
Recent activity
- 2026-10-20 — latest release on wordpress.org (3.2.0).
- 2026-07-02 — Cross-site scripting (XSS) disclosed (CVE-2026-57345), fixed in 3.0.4.
- 2025-09-20 — Cross-site request forgery (CSRF) disclosed (CVE-2025-9949), fixed in 3.0.2.
- 2025-01-24 — Missing authorization check disclosed (CVE-2025-24679), fixed in 2.5.3.
Get an email when Internal Links Manager has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Internal Links Manager (seo-automated-link-building) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1) · Cross-site request forgery (CSRF) (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/seo-automated-link-building (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/seo-automated-link-building"><img src="https://laskyr.com/plugins/seo-automated-link-building/badge.svg" alt="Internal Links Manager vulnerability status"></a>