Skip to content
Laskyr

Plugins · sendpulse-email-marketing-newsletter · data as of 2026-11-04

Is SendPulse Email Marketing Newsletter safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.7)

As of 2026-11-04. 4 issues are on record for older versions; version 2.2.6 or newer fixes all of them that state a fix.

Latest version
2.2.7
Last updated
2026-09-03
Active installs
1,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 8.0+

Add a customizable email subscription form to your site, send newsletters, and automate email campaigns with autoresponders using SendPulse. — by SendPulse

What to do

  1. Update to the latest version (2.2.7). Anything older than 2.2.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get sendpulse-email-marketing-newsletter --field=version shows what you run; wp plugin update sendpulse-email-marketing-newsletter updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-13362 · published 2026-08-01

Stored cross-site scripting (XSS) in SendPulse Email Marketing Newsletter (2.2.5 and older)

Affected
2.2.5 and older
Fixed in
2.2.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The SendPulse Email Marketing Newsletter plugin for WordPress is vulnerable to Stored Cross-Site Scripting via _sp_form_code Post Meta in all versions up to, and including, 2.2.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires the attacker to create a sendpulse_form post containing a benign SendPulse loader script tag alongside arbitrary HTML (e.g., an img onerror payload), which bypasses the allow-list check and executes in the browser of any user — including administrators — who previews or views a page rendering the [sendpulse-form] shortcode.

NVD CVE-2026-13362Wordfence advisoryPlugin source

medium 4.3 CVE-2025-67948 · published 2025-12-16

Information disclosure in SendPulse Email Marketing Newsletter (2.2.1 and older)

Affected
2.2.1 and older
Fixed in
2.2.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in SendPulse SendPulse Email Marketing Newsletter sendpulse-email-marketing-newsletter allows Retrieve Embedded Sensitive Data.This issue affects SendPulse Email Marketing Newsletter: from n/a through <= 2.2.1.

NVD CVE-2025-67948Patchstack advisory

medium 5.4 CVE-2025-47547 · published 2025-05-07

Stored cross-site scripting (XSS) in SendPulse Email Marketing Newsletter (2.1.6 and older)

Affected
2.1.6 and older
Fixed in
2.1.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in SendPulse SendPulse Email Marketing Newsletter sendpulse-email-marketing-newsletter allows Stored XSS.This issue affects SendPulse Email Marketing Newsletter: from n/a through <= 2.1.6.

NVD CVE-2025-47547Patchstack advisory

medium 6.5 CVE-2025-22662 · published 2025-02-04

Stored cross-site scripting (XSS) in SendPulse Email Marketing Newsletter (2.1.5 and older)

Affected
2.1.5 and older
Fixed in
2.1.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in SendPulse SendPulse Email Marketing Newsletter sendpulse-email-marketing-newsletter allows Stored XSS.This issue affects SendPulse Email Marketing Newsletter: from n/a through <= 2.1.5.

NVD CVE-2025-22662Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
SendPulse Email Marketing Newsletter vulnerability status badge
<a href="https://laskyr.com/plugins/sendpulse-email-marketing-newsletter"><img src="https://laskyr.com/plugins/sendpulse-email-marketing-newsletter/badge.svg" alt="SendPulse Email Marketing Newsletter vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit