Skip to content
Laskyr

Plugins · sender-net-automated-emails · data as of 2026-11-04

Is Sender safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.11.2)

As of 2026-11-04. 3 issues are on record for older versions; version 2.10.23 or newer fixes all of them that state a fix.

Latest version
2.11.2
Last updated
2026-10-27
Active installs
6,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.1+

Sender is an all-in-one email & SMS marketing platform designed keeping the challenges of ecommerce and small businesses in mind. — by Sender

What to do

  1. Update to the latest version (2.11.2). Anything older than 2.10.23 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get sender-net-automated-emails --field=version shows what you run; wp plugin update sender-net-automated-emails updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.6 CVE-2026-59537 · published 2026-07-27

SQL injection in Sender (2.10.22 and older)

Affected
2.10.22 and older
Fixed in
2.10.23
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Administrator SQL Injection in Sender – Newsletter, SMS and Email Marketing Automation for WooCommerce <= 2.10.22 versions.

NVD CVE-2026-59537Patchstack advisory

high 8.8 CVE-2024-39657 · published 2024-08-26

Cross-site request forgery (CSRF) in Sender (2.6.18 and older)

Affected
2.6.18 and older
Fixed in
2.6.19
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Sender Sender – Newsletter, SMS and Email Marketing Automation for WooCommerce.This issue affects Sender – Newsletter, SMS and Email Marketing Automation for WooCommerce: from n/a through 2.6.18.

NVD CVE-2024-39657Patchstack advisory

high 7.1 CVE-2024-43126 · published 2024-08-12

Reflected cross-site scripting (XSS) in Sender (2.6.14 and older)

Affected
2.6.14 and older
Fixed in
2.6.16
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Sender Sender – Newsletter, SMS and Email Marketing Automation for WooCommerce allows Reflected XSS.This issue affects Sender – Newsletter, SMS and Email Marketing Automation for WooCommerce: from n/a through 2.6.14.

NVD CVE-2024-43126Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Sender vulnerability status badge
<a href="https://laskyr.com/plugins/sender-net-automated-emails"><img src="https://laskyr.com/plugins/sender-net-automated-emails/badge.svg" alt="Sender vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit