Skip to content
Laskyr

Plugins · sell-btc-by-hayyatapps · data as of 2026-11-04

Is Sell BTC by Hayyat Apps safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0)

As of 2026-11-04. 1 issue is on record for older versions; version 1.6 or newer fixes all of them that state a fix.

Latest version
2.0
Last updated
2026-07-25
Active installs
10+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Turn WooCommerce into a crypto exchange: a live conversion calculator with your own rates, markup, fees and rate-locked orders. — by hayyatapps

What to do

  1. Update to the latest version (2.0). Anything older than 1.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get sell-btc-by-hayyatapps --field=version shows what you run; wp plugin update sell-btc-by-hayyatapps updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2025-14554 · published 2026-01-31

Stored cross-site scripting (XSS) in Sell BTC by Hayyat Apps (1.5 and older)

Affected
1.5 and older
Fixed in
1.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Sell BTC - Cryptocurrency Selling Calculator plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'orderform_data' AJAX action in all versions up to, and including, 1.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in order records that will execute whenever an administrator accesses the Orders page in the admin dashboard. The vulnerability was partially patched in version 1.5.

NVD CVE-2025-14554Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Sell BTC by Hayyat Apps vulnerability status badge
<a href="https://laskyr.com/plugins/sell-btc-by-hayyatapps"><img src="https://laskyr.com/plugins/sell-btc-by-hayyatapps/badge.svg" alt="Sell BTC by Hayyat Apps vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit