Skip to content
Laskyr

Plugins · security-hardener · data as of 2026-11-04

Is Security Hardener safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.7)

As of 2026-11-04. 1 issue is on record for older versions; version 2.4.5 or newer fixes all of them that state a fix.

Latest version
2.4.7
Last updated
2026-10-28
Active installs
200+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.2+

Hardens WordPress with secure headers, login protection, user enumeration blocking, rate limiting, and a built-in security checklist. — by Marc Armengou

What to do

  1. Update to the latest version (2.4.7). Anything older than 2.4.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get security-hardener --field=version shows what you run; wp plugin update security-hardener updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-16149 · published 2026-08-23

Missing authorization check in Security Hardener (2.4.4 and older)

Affected
2.4.4 and older
Fixed in
2.4.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Security Hardener plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 2.4.4. The vulnerability exists because the plugin's user-enumeration protection, which is enabled by default, hooks the rest_endpoints filter via secure_user_endpoints() and overwrites every registered handler's permission_callback on both the /wp/v2/users and /wp/v2/users/(?P<id>[\d]+) routes — including POST, PUT, PATCH, and DELETE handlers — with a bare closure that returns only is_user_logged_in(), completely stripping WordPress Core's original capability checks such as create_users, promote_user, edit_users, and delete_users that WP_REST_Users_Controller normally enforces. This makes it possible for authenticated attackers with Subscriber-level access and above to create new Administrator accounts by sending POST request to /wp/v2/users with administrator role, or to reset an existing Administrator's password by issuing a PUT/POST request to /wp/v2/users/<id>. Because the block_user_enum option defaults to enabled, no special plugin configuration is required — the overwrite is active on every request as soon as the plugin is installed.

NVD CVE-2026-16149Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Security Hardener vulnerability status badge
<a href="https://laskyr.com/plugins/security-hardener"><img src="https://laskyr.com/plugins/security-hardener/badge.svg" alt="Security Hardener vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit