Skip to content
Laskyr

Plugins · secupress · data as of 2026-11-04

Is SecuPress with Simple SSL safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.7.3)

As of 2026-11-04. 5 issues are on record for older versions; version 2.7 or newer fixes all of them that state a fix.

Latest version
2.7.3
Last updated
2026-10-22
Active installs
40,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.3+

Protect your WordPress with SecuPress, analyze and ensure the safety of your website daily. — by SecuPress

What to do

  1. Update to the latest version (2.7.3). Anything older than 2.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get secupress --field=version shows what you run; wp plugin update secupress updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2024-43228 · published 2026-02-20

Missing authorization check in SecuPress with Simple SSL (2.2.5.3 and older)

Affected
2.2.5.3 and older
Fixed in
2.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in SecuPress SecuPress Free secupress.This issue affects SecuPress Free: from n/a through <= 2.2.5.3.

NVD CVE-2024-43228Patchstack advisory

medium 4.3 CVE-2025-3452 · published 2025-04-29

Missing authorization check in SecuPress with Simple SSL (2.3.9 and older)

Affected
2.3.9 and older
Fixed in
2.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The SecuPress Free — WordPress Security plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'secupress_reinstall_plugins_admin_ajax_cb' function in all versions up to, and including, 2.3.9. This makes it possible for authenticated attackers, with Subscriber-level access and above, to install arbitrary plugins.

NVD CVE-2025-3452Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2025-30907 · published 2025-03-27

Cross-site scripting (XSS) in SecuPress with Simple SSL (2.2.5.3 and older)

Affected
2.2.5.3 and older
Fixed in
2.2.5.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in SecuPress SecuPress Free secupress allows DOM-Based XSS.This issue affects SecuPress Free: from n/a through <= 2.2.5.3.

NVD CVE-2025-30907Patchstack advisory

medium 5.4 CVE-2024-9019 · published 2025-02-28

Stored cross-site scripting (XSS) in SecuPress with Simple SSL (2.2.5.3 and older)

Affected
2.2.5.3 and older
Fixed in
2.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The SecuPress Free — WordPress Security plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's secupress_check_ban_ips_form shortcode in all versions up to, and including, 2.2.5.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-9019Wordfence advisoryCode change (fix)

medium 4.3 CVE-2024-1504 · published 2024-04-02

Cross-site request forgery (CSRF) in SecuPress with Simple SSL (2.2.5.1 and older)

Affected
2.2.5.1 and older
Fixed in
2.7 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The SecuPress Free — WordPress Security plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.2.5.1. This is due to missing or incorrect nonce validation on the secupress_blackhole_ban_ip() function. This makes it possible for unauthenticated attackers to block a user's IP via a forged request granted they can trick the user into performing an action such as clicking on a link.

NVD CVE-2024-1504Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
SecuPress with Simple SSL vulnerability status badge
<a href="https://laskyr.com/plugins/secupress"><img src="https://laskyr.com/plugins/secupress/badge.svg" alt="SecuPress with Simple SSL vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit