Skip to content
Laskyr

Plugins · searchpro · data as of 2026-11-04

Is BerqWP safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.1.20)

As of 2026-11-04. 6 issues are on record for older versions; version 4.1.16 or newer fixes all of them that state a fix.

Latest version
4.1.20
Last updated
2026-10-13
Active installs
4,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Automatically boost your PageSpeed score to 90+ for both mobile & desktop and pass Core Web Vitals for WordPress website without any technical skills. — by BerqWP

What to do

  1. Update to the latest version (4.1.20). Anything older than 4.1.16 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get searchpro --field=version shows what you run; wp plugin update searchpro updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-78528 · published 2026-09-17

Missing authorization check in BerqWP (4.1.15 and older)

Affected
4.1.15 and older
Fixed in
4.1.16
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in BerqWP <= 4.1.15 versions.

NVD CVE-2026-78528Patchstack advisory

medium 5.3 CVE-2025-58979 · published 2025-09-09

Missing authorization check in BerqWP (2.2.53 and older)

Affected
2.2.53 and older
Fixed in
2.2.54
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in BerqWP BerqWP searchpro allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects BerqWP: from n/a through <= 2.2.53.

NVD CVE-2025-58979Patchstack advisory

high 8.1 CVE-2025-7443 · published 2025-08-01

Arbitrary file upload in BerqWP (2.2.42 and older)

Affected
2.2.42 and older
Fixed in
2.2.44 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The BerqWP – Automated All-In-One Page Speed Optimization for Core Web Vitals, Cache, CDN, Images, CSS, and JavaScript plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation via the store_javascript_cache.php file in all versions up to, and including, 2.2.42. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible.

NVD CVE-2025-7443Wordfence advisoryCode change (fix)Plugin source

medium 6.1 CVE-2024-9344 · published 2024-10-02

Reflected cross-site scripting (XSS) in BerqWP (2.1.1 and older)

Affected
2.1.1 and older
Fixed in
2.1.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The BerqWP – Automated All-In-One PageSpeed Optimization Plugin for Core Web Vitals, Cache, CDN, Images, CSS, and JavaScript plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'url' parameter in all versions up to, and including, 2.1.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-9344Wordfence advisoryCode change (fix)Plugin source

critical 10.0 CVE-2024-43160 · published 2024-08-13

Arbitrary file upload in BerqWP (1.7.6 and older)

Affected
1.7.6 and older
Fixed in
1.7.7
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unrestricted Upload of File with Dangerous Type vulnerability in BerqWP allows Code Injection.This issue affects BerqWP: from n/a through 1.7.6.

NVD CVE-2024-43160Patchstack advisory

high 7.2 CVE-2024-37942 · published 2024-07-22

Server-side request forgery (SSRF) in BerqWP (1.7.5 and older)

Affected
1.7.5 and older
Fixed in
1.7.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Server-Side Request Forgery (SSRF) vulnerability in Berqier Ltd BerqWP.This issue affects BerqWP: from n/a through 1.7.5.

NVD CVE-2024-37942Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
BerqWP vulnerability status badge
<a href="https://laskyr.com/plugins/searchpro"><img src="https://laskyr.com/plugins/searchpro/badge.svg" alt="BerqWP vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit