Skip to content
Laskyr

Plugins · search-regex · data as of 2026-11-04

Is Search Regex safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.5.1)

As of 2026-11-04. 1 issue is on record for older versions; version 3.5.1 or newer fixes all of them that state a fix.

Latest version
3.5.1
Last updated
2026-10-06
Active installs
100,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Search Regex adds a powerful set of search and replace functions to WordPress posts, pages, custom post types, and other data. — by John Godley

What to do

  1. Update to the latest version (3.5.1). Anything older than 3.5.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get search-regex --field=version shows what you run; wp plugin update search-regex updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.0 CVE-2026-104932 · published 2026-10-16

PHP object injection in Search Regex (3.5 and older)

Affected
3.5 and older
Fixed in
3.5.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Search Regex plugin for WordPress is vulnerable to PHP Object Injection in version 3.5 via deserialization of untrusted input in the replace_all function. This allows authenticated attackers, with subscriber-level access and above, to inject a PHP Object. The additional presence of a POP chain allows attackers to execute code.

NVD CVE-2026-104932Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Search Regex vulnerability status badge
<a href="https://laskyr.com/plugins/search-regex"><img src="https://laskyr.com/plugins/search-regex/badge.svg" alt="Search Regex vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit