Skip to content
Laskyr

Plugins · search-in-place · data as of 2026-11-04

Is Search in Place safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.7)

As of 2026-11-04. 2 issues are on record for older versions; version 1.5.6 or newer fixes all of them that state a fix.

Latest version
1.5.7
Last updated
2026-09-30
Active installs
3,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4

Search in Place improves blog search by displaying query results in real time. It displays the results dynamically as you enter the search criteria. — by codepeople

What to do

  1. Update to the latest version (1.5.7). Anything older than 1.5.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get search-in-place --field=version shows what you run; wp plugin update search-in-place updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-95598 · published 2026-10-09

Reflected cross-site scripting (XSS) in Search in Place (1.5.5 and older)

Affected
1.5.5 and older
Fixed in
1.5.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in codepeople Search in Place search-in-place allows Reflected XSS.This issue affects Search in Place: from n/a through 1.5.5.

NVD CVE-2026-95598Patchstack advisory

medium 4.3 CVE-2023-26521 · published 2024-06-03

Missing authorization check in Search in Place (1.0.104 and older)

Affected
1.0.104 and older
Fixed in
1.0.105
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in CodePeople Search in Place allows Functionality Misuse.This issue affects Search in Place: from n/a through 1.0.104.

NVD CVE-2023-26521Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Search in Place vulnerability status badge
<a href="https://laskyr.com/plugins/search-in-place"><img src="https://laskyr.com/plugins/search-in-place/badge.svg" alt="Search in Place vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit