Plugins · search-exclude · data as of 2026-11-04
Is Search Exclude safe? Known vulnerabilities and latest version
- Latest version
- 2.6.8
- Last updated
- 2026-10-05
- Active installs
- 50,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
Hide any post or page from the search results. — by quadlayers
What to do
- Update to the latest version (2.6.8). Anything older than 2.5.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get search-exclude --field=version shows what you run; wp plugin update search-exclude updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2025-10646 · published 2025-11-25
Missing authorization check in Search Exclude (2.5.7 and older)
- Affected
- 2.5.7 and older
- Fixed in
- 2.5.8 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Search Exclude plugin for WordPress is vulnerable to unauthorized modification of data due to a insufficient capability check on the Base::get_rest_permission() method in all versions up to, and including, 2.5.7. This makes it possible for authenticated attackers, with Contributor-level access and above, to modify plugin settings, such as adding arbitrary posts to the search exclusion list.
medium 5.3 CVE-2025-2821 · published 2025-05-07
Missing authorization check in Search Exclude (2.4.9 and older)
- Affected
- 2.4.9 and older
- Fixed in
- 2.5.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Search Exclude plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the get_rest_permission function in all versions up to, and including, 2.4.9. This makes it possible for unauthenticated attackers to modify plugin settings, excluding content from search results.
NVD CVE-2025-2821Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2022-36282 · published 2022-08-23
Stored cross-site scripting (XSS) in Search Exclude (1.2.6 and older)
- Affected
- 1.2.6 and older
- Fixed in
- 1.2.7 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Authenticated (editor+) Stored Cross-Site Scripting (XSS) vulnerability in Roman Pronskiy's Search Exclude plugin <= 1.2.6 at WordPress.
high 7.5 CVE-2019-15895 · published 2019-09-09
Authentication bypass in Search Exclude (older than 1.2.4)
- Affected
- older than 1.2.4
- Fixed in
- 1.2.4
- Access needed (per CVSS)
- No login needed
- Range from
- NVD analysis · score by NVD
Details from the advisory
search-exclude.php in the "Search Exclude" plugin before 1.2.4 for WordPress allows unauthenticated options changes.
NVD CVE-2019-15895wordpress.orgblog.nintechnet.comwpvulndb.com
Recent activity
- 2026-10-05 — latest release on wordpress.org (2.6.8).
- 2025-11-25 — Missing authorization check disclosed (CVE-2025-10646), fixed in 2.5.8.
- 2025-05-07 — Missing authorization check disclosed (CVE-2025-2821), fixed in 2.5.0.
- 2022-08-23 — Stored cross-site scripting (XSS) disclosed (CVE-2022-36282), fixed in 1.2.7.
Get an email when Search Exclude has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Search Exclude (search-exclude) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by quadlayers (7 tracked)
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (1) · Authentication bypass (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/search-exclude (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/search-exclude"><img src="https://laskyr.com/plugins/search-exclude/badge.svg" alt="Search Exclude vulnerability status"></a>