Skip to content
Laskyr

Plugins · search-analytics · data as of 2026-11-04

Is Search Analytics for WP safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.6.0)

As of 2026-11-04. 6 issues are on record for older versions; version 1.5.0 or newer fixes all of them that state a fix.

Latest version
1.6.0
Last updated
2026-09-28
Active installs
3,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

See what visitors search for on your site and which searches come up empty. Popular search terms and statistics, stored in your own database. — by Cornel Raiu

What to do

  1. Update to the latest version (1.6.0). Anything older than 1.5.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get search-analytics --field=version shows what you run; wp plugin update search-analytics updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.1 CVE-2026-7444 · published 2026-08-05

Cross-site request forgery (CSRF) in Search Analytics for WP (1.4.16 and older)

Affected
1.4.16 and older
Fixed in
1.5.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Search Analytics for WP plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.4.16. This is due to missing or incorrect nonce validation on the `process_bulk_action()` function of `MWTSA_Stats_Table`. This makes it possible for unauthenticated attackers to delete arbitrary search-term records, including all associated search-history rows, via a forged request granted they can trick a user with access to the plugin's "Search Analytics" dashboard page (Administrator by default) into performing an action such as clicking on a link.

NVD CVE-2026-7444Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 5.3 CVE-2026-27357 · published 2026-05-25

Missing authorization check in Search Analytics for WP (older than 1.5.0)

Affected
older than 1.5.0
Fixed in
1.5.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Cornel Raiu WP Search Analytics allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects WP Search Analytics: from n/a before 1.5.0.

NVD CVE-2026-27357Patchstack advisory

medium 4.3 CVE-2024-43229 · published 2024-11-01

Missing authorization check in Search Analytics for WP (1.4.9 and older)

Affected
1.4.9 and older
Fixed in
1.4.10
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Cornel Raiu WP Search Analytics search-analytics.This issue affects WP Search Analytics: from n/a through <= 1.4.9.

NVD CVE-2024-43229Patchstack advisory

medium 6.1 CVE-2024-9209 · published 2024-10-01

Reflected cross-site scripting (XSS) in Search Analytics for WP (1.4.10 and older)

Affected
1.4.10 and older
Fixed in
1.4.11 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Search Analytics plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 1.4.10. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-9209Wordfence advisoryCode change (fix)Plugin source

medium 6.1 CVE-2023-30471 · published 2023-09-27

Reflected cross-site scripting (XSS) in Search Analytics for WP (1.4.7 and older)

Affected
1.4.7 and older
Fixed in
1.4.8
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Cornel Raiu WP Search Analytics plugin <= 1.4.7 versions.

NVD CVE-2023-30471Patchstack advisory

medium 4.8 CVE-2022-47587 · published 2023-05-10

Stored cross-site scripting (XSS) in Search Analytics for WP (1.4.5 and older)

Affected
1.4.5 and older
Fixed in
1.4.6
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Cornel Raiu WP Search Analytics plugin <= 1.4.5 versions.

NVD CVE-2022-47587Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Search Analytics for WP vulnerability status badge
<a href="https://laskyr.com/plugins/search-analytics"><img src="https://laskyr.com/plugins/search-analytics/badge.svg" alt="Search Analytics for WP vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit