Plugins · scripts-n-styles · data as of 2026-11-04
Is Scripts n Styles safe? Known vulnerabilities and latest version
- Latest version
- 3.5.8
- Last updated
- 2023-06-06
- Active installs
- 30,000+
- Known issues on record
- 2
- Unpatched in latest
- 1
- Tested up to WP
- 6.2.15 · PHP 7.4+
This plugin allows Admin users to individually add HTML, custom CSS, Classes and JavaScript directly to Post, Pages or any other custom post types. — by WraithKenny
What to do
- There is no fixed version yet. If you can live without Scripts n Styles for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get scripts-n-styles --field=version shows what you run; wp plugin update scripts-n-styles updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 affects latest 3.5.8 CVE-2026-62042 · published 2026-10-09
Missing authorization check in Scripts n Styles (3.5.8 and older)
- Affected
- 3.5.8 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in unFocus Projects Scripts n Styles scripts-n-styles allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Scripts n Styles: from n/a through 3.5.8.
medium 4.8 CVE-2023-31236 · published 2023-06-12
Stored cross-site scripting (XSS) in Scripts n Styles (3.5.7 and older)
- Affected
- 3.5.7 and older
- Fixed in
- 3.5.8
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in unFocus Projects Scripts n Styles plugin <= 3.5.7 versions.
Recent activity
- 2023-06-06 — latest release on wordpress.org (3.5.8).
- 2026-10-09 — Missing authorization check disclosed (CVE-2026-62042), no fix listed yet.
- 2023-06-12 — Stored cross-site scripting (XSS) disclosed (CVE-2023-31236), fixed in 3.5.8.
Get an email when Scripts n Styles has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Scripts n Styles (scripts-n-styles) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/scripts-n-styles (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/scripts-n-styles"><img src="https://laskyr.com/plugins/scripts-n-styles/badge.svg" alt="Scripts n Styles vulnerability status"></a>