Skip to content
Laskyr

Plugins · school-management-system · data as of 2026-11-04

Is The School Management safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.6)

As of 2026-11-04. 2 issues are on record for older versions; version 5.5 or newer fixes all of them that state a fix.

Latest version
5.6
Last updated
2026-09-12
Active installs
700+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4

The School Management System is a complete, feature-rich WordPress plugin designed to seamlessly manage all aspects of school administration and educa … — by Weblizar - WordPress Themes & Plugin

What to do

  1. Update to the latest version (5.6). Anything older than 5.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get school-management-system --field=version shows what you run; wp plugin update school-management-system updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-9767 · published 2026-08-16

Cross-site request forgery (CSRF) in The School Management (5.4 and older)

Affected
5.4 and older
Fixed in
5.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The The School Management – Education & Learning ERP plugin for WordPress is vulnerable to generic SQL Injection via 'order[0][dir]' Parameter in all versions up to, and including, 5.4 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with custom-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. This vulnerability is replicated across seven or more AJAX handlers including wlsm-fetch-staff-classes, wlsm-fetch-notices, wlsm-fetch-subjects, wlsm-fetch-inquiries, wlsm-fetch-staff-employee, and wlsm-fetch-payments, and the missing nonce verification on several of these handlers also enables CSRF-chained exploitation.

NVD CVE-2026-9767Wordfence advisoryCode change (fix)Plugin source

critical 9.8 CVE-2022-47430 · published 2023-11-06

SQL injection in The School Management (4.1 and older)

Affected
4.1 and older
Fixed in
4.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Weblizar The School Management – Education & Learning Management allows SQL Injection.This issue affects The School Management – Education & Learning Management: from n/a through 4.1.

NVD CVE-2022-47430Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
The School Management vulnerability status badge
<a href="https://laskyr.com/plugins/school-management-system"><img src="https://laskyr.com/plugins/school-management-system/badge.svg" alt="The School Management vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit