Skip to content
Laskyr

Plugins · sastra-essential-addons-for-elementor · data as of 2026-11-04

Is Spexo Addons for Elementor safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.38)

As of 2026-11-04. 4 issues are on record for older versions; version 1.0.24 or newer fixes all of them that state a fix.

Latest version
1.0.38
Last updated
2026-07-18
Active installs
6,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Advanced Elementor addons plugin with widgets, WooCommerce builder, mega menu, popup builder and Elementor template kits for faster website design. — by Fast Themes

What to do

  1. Update to the latest version (1.0.38). Anything older than 1.0.24 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get sastra-essential-addons-for-elementor --field=version shows what you run; wp plugin update sastra-essential-addons-for-elementor updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 1 record(s) do not state which versions are affected.

high 7.2 CVE-2026-118077 · published 2026-10-29

PHP object injection in Spexo Addons for Elementor (1.2.3 and older)

Affected
1.2.3 and older
Fixed in
unknown
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack

Note: the source's version range goes past the newest Spexo Addons for Elementor release on wordpress.org (1.0.38), so it probably describes a paid edition with its own version numbers, or contains a typo. We do not use it to judge your version.

Details from the advisory

Author PHP Object Injection in Sastra Essential Addons for Elementor <= 1.2.3 versions.

NVD CVE-2026-118077Patchstack advisory

medium 6.4 CVE-2025-8208 · published 2025-08-24

Stored cross-site scripting (XSS) in Spexo Addons for Elementor (1.0.23 and older)

Affected
1.0.23 and older
Fixed in
1.0.24 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Spexo Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Countdown widget in all versions up to, and including, 1.0.23 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-8208Wordfence advisoryCode change (fix)wordpress.org

medium 4.3 CVE-2024-13335 · published 2025-01-24

Missing authorization check in Spexo Addons for Elementor (1.0.14 and older)

Affected
1.0.14 and older
Fixed in
1.0.15 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Spexo Addons for Elementor – Free Elementor Addons, Widgets and Templates plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on the tmpcoder_theme_install_func() function in all versions up to, and including, 1.0.14. This makes it possible for authenticated attackers, with Subscriber-level access and above, to install a theme.

NVD CVE-2024-13335Wordfence advisoryCode change (fix)

medium 6.5 CVE-2024-51674 · published 2024-11-09

Cross-site scripting (XSS) in Spexo Addons for Elementor (1.0.5 and older)

Affected
1.0.5 and older
Fixed in
1.0.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Fast Themes Sastra Essential Addons for Elementor sastra-essential-addons-for-elementor allows DOM-Based XSS.This issue affects Sastra Essential Addons for Elementor: from n/a through <= 1.0.5.

NVD CVE-2024-51674Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Spexo Addons for Elementor vulnerability status badge
<a href="https://laskyr.com/plugins/sastra-essential-addons-for-elementor"><img src="https://laskyr.com/plugins/sastra-essential-addons-for-elementor/badge.svg" alt="Spexo Addons for Elementor vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit