Plugins · same-category-posts · data as of 2026-11-04
Is Same Category Posts safe? Known vulnerabilities and latest version
- Latest version
- 1.2.1
- Last updated
- 2026-09-23
- Active installs
- 3,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.2+
Show posts related to the current category or other custom post types. — by Daniel Floeter
What to do
- Update to the latest version (1.2.1). Anything older than 1.1.20 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get same-category-posts --field=version shows what you run; wp plugin update same-category-posts updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 CVE-2025-14797 · published 2026-01-24
Stored cross-site scripting (XSS) in Same Category Posts (1.1.19 and older)
- Affected
- 1.1.19 and older
- Fixed in
- 1.1.20 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Same Category Posts plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the widget title placeholder functionality in all versions up to, and including, 1.1.19. This is due to the use of `htmlspecialchars_decode()` on taxonomy term names before output, which decodes HTML entities that WordPress intentionally encodes for safety. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2025-14797Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-09-23 — latest release on wordpress.org (1.2.1).
- 2026-01-24 — Stored cross-site scripting (XSS) disclosed (CVE-2025-14797), fixed in 1.1.20.
Get an email when Same Category Posts has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Same Category Posts (same-category-posts) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/same-category-posts (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/same-category-posts"><img src="https://laskyr.com/plugins/same-category-posts/badge.svg" alt="Same Category Posts vulnerability status"></a>