Skip to content
Laskyr

Plugins · safe-svg · data as of 2026-11-01

Is Safe SVG safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.5.2)

As of 2026-11-01. 6 issues are on record for older versions; version 2.5.1 or newer fixes all of them that state a fix.

Latest version
2.5.2
Last updated
2026-10-26
Active installs
1+ million
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Enable SVG uploads and sanitize them to stop XML/SVG vulnerabilities in your WordPress website. — by 10up

What to do

  1. Update to the latest version (2.5.2). Anything older than 2.5.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get safe-svg --field=version shows what you run; wp plugin update safe-svg updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-94672 · published 2026-09-30

Missing authorization check in Safe SVG (2.5.0 and older)

Affected
2.5.0 and older
Fixed in
2.5.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Insecure Direct Object References (IDOR) in Safe SVG <= 2.5.0 versions.

NVD CVE-2026-94672Patchstack advisory

medium 6.5 CVE-2026-94077 · published 2026-09-30

Cross-site scripting (XSS) in Safe SVG (2.5.0 and older)

Affected
2.5.0 and older
Fixed in
2.5.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Cross Site Scripting (XSS) in Safe SVG <= 2.5.0 versions.

NVD CVE-2026-94077Patchstack advisory

medium 4.8 CVE-2024-8378 · published 2024-11-07

Security issue in Safe SVG (older than 2.2.6)

Affected
older than 2.2.6
Fixed in
2.2.6
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Safe SVG WordPress plugin before 2.2.6 has its sanitisation code is only running for paths that call wp_handle_upload, but not for example for code that uses wp_handle_sideload which is often used to upload attachments via raw POST data.

NVD CVE-2024-8378WPScan advisory

medium 6.1 CVE-2022-1091 · published 2022-04-18

Cross-site scripting (XSS) in Safe SVG (older than 1.9.10)

Affected
older than 1.9.10
Fixed in
1.9.10
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The sanitisation step of the Safe SVG WordPress plugin before 1.9.10 can be bypassed by spoofing the content-type in the POST request to upload a file. Exploiting this vulnerability, an attacker will be able to perform the kinds of attacks that this plugin should prevent (mainly XSS, but depending on further use of uploaded SVG files potentially other XML attacks).

NVD CVE-2022-1091WPScan advisorygithub.com

high 7.5 CVE-2019-18854 · published 2019-11-11

Denial of service in Safe SVG (1.9.4 and older)

Affected
1.9.4 and older
Fixed in
1.9.5 *
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

A Denial Of Service vulnerability exists in the safe-svg (aka Safe SVG) plugin through 1.9.4 for WordPress, related to unlimited recursion for a '<use ... xlink:href="#identifier">' substring.

NVD CVE-2019-18854Code change (fix)wordpress.orgfortiguard.comwpvulndb.com

high 7.5 CVE-2019-18855 · published 2019-11-11

Denial of service in Safe SVG (1.9.4 and older)

Affected
1.9.4 and older
Fixed in
1.9.5 *
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

A Denial Of Service vulnerability exists in the safe-svg (aka Safe SVG) plugin through 1.9.4 for WordPress, related to potentially unwanted elements or attributes.

NVD CVE-2019-18855Code change (fix)wordpress.orgfortiguard.comwpvulndb.com

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Safe SVG vulnerability status badge
<a href="https://laskyr.com/plugins/safe-svg"><img src="https://laskyr.com/plugins/safe-svg/badge.svg" alt="Safe SVG vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit