Skip to content
Laskyr

Plugins · s2b-ai-assistant · data as of 2026-11-04

Is S2B AI Assistant safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.9.8)

As of 2026-11-04. 1 issue is on record for older versions; version 1.7.9 or newer fixes all of them that state a fix.

Latest version
1.9.8
Last updated
2026-09-21
Active installs
40+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Build AI chatbots, use AI workflows, detect chatbot placements with Chatbot Inspector, and create AI images. — by oc3dots

What to do

  1. Update to the latest version (1.9.8). Anything older than 1.7.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get s2b-ai-assistant --field=version shows what you run; wp plugin update s2b-ai-assistant updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2025-12973 · published 2025-11-21

Arbitrary file upload in S2B AI Assistant (1.7.8 and older)

Affected
1.7.8 and older
Fixed in
1.7.9 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The S2B AI Assistant – ChatBot, ChatGPT, OpenAI, Content & Image Generator plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the storeFile() function in all versions up to, and including, 1.7.8. This makes it possible for authenticated attackers, with Editor-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible.

NVD CVE-2025-12973Wordfence advisoryCode change (fix)github.comryankozak.comPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
S2B AI Assistant vulnerability status badge
<a href="https://laskyr.com/plugins/s2b-ai-assistant"><img src="https://laskyr.com/plugins/s2b-ai-assistant/badge.svg" alt="S2B AI Assistant vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit