Plugins · rt-mega-menu · data as of 2026-11-04
Is RT Mega Menu safe? Known vulnerabilities and latest version
- Status
- Closed 2026-08-17
- Known issues on record
- 5
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate rt-mega-menu && wp plugin delete rt-mega-menu
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 5 record(s) do not state which versions are affected.
medium 6.4 CVE-2026-14855 · published 2026-09-18
Stored cross-site scripting (XSS) in RT Mega Menu (1.5.1 and older)
- Affected
- 1.5.1 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The RT Mega Menu plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'css[left]' parameter in all versions up to, and including, 1.5.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-14855Wordfence advisoryCode change (fix)Plugin source
medium 6.4 CVE-2026-15650 · published 2026-09-18
Stored cross-site scripting (XSS) in RT Mega Menu (1.5.2 and older)
- Affected
- 1.5.2 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The RT Mega Menu – Mega Menu Builder for Elementor & Gutenberg plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'pointer_menu_item' Block Attribute in all versions up to, and including, 1.5.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The payload bypasses wp_kses_post filtering applied to post content on save because it contains no HTML tags and survives intact inside the block comment's JSON attributes, reaching the walker unescaped at render time.
medium 5.4 CVE-2026-15385 · published 2026-08-02
Cross-site scripting (XSS) in RT Mega Menu (older than 1.5.2)
- Affected
- older than 1.5.2
- Fixed in
- 1.5.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The RT Mega Menu WordPress plugin before 1.5.2 does not perform a capability check on the AJAX action that saves mega-menu configuration and per-menu-item settings; its only gate is a nonce that any logged-in user can read from a standard admin page. A subscriber-level user can therefore enable the mega menu on a site menu and store a menu-item style value that is rendered, without output escaping, into a style attribute on the public navigation. By breaking out of that attribute the user persists a JavaScript event handler that executes for every visitor who hovers the navigation, including administrators, leading to session/site takeover.
medium 6.5 CVE-2026-65433 · published 2026-07-27
Missing authorization check in RT Mega Menu (1.5.1 and older)
- Affected
- 1.5.1 and older
- Fixed in
- 1.5.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber Broken Access Control in RT Mega Menu – Mega Menu Builder for Elementor & Gutenberg <= 1.5.1 versions.
medium 6.5 CVE-2026-59559 · published 2026-07-27
Cross-site scripting (XSS) in RT Mega Menu (1.5.1 and older)
- Affected
- 1.5.1 and older
- Fixed in
- 1.5.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber Cross Site Scripting (XSS) in RT Mega Menu – Mega Menu Builder for Elementor & Gutenberg <= 1.5.1 versions.
Recent activity
- 2026-08-17 — closed on wordpress.org (Guideline Violation).
- 2026-09-18 — Stored cross-site scripting (XSS) disclosed (CVE-2026-14855), fix version not stated.
- 2026-09-18 — Stored cross-site scripting (XSS) disclosed (CVE-2026-15650), fix version not stated.
- 2026-08-02 — Cross-site scripting (XSS) disclosed (CVE-2026-15385), fixed in 1.5.2.
Get an email when RT Mega Menu has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for RT Mega Menu (rt-mega-menu) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (4) · Missing authorization (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/rt-mega-menu (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/rt-mega-menu"><img src="https://laskyr.com/plugins/rt-mega-menu/badge.svg" alt="RT Mega Menu vulnerability status"></a>