Skip to content
Laskyr

Plugins · rss-feed-widget · data as of 2026-11-04

Is RSS Feed Widget safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.0.0)

As of 2026-11-04. 6 issues are on record for older versions; version 3.0.3 or newer fixes all of them that state a fix.

Latest version
4.0.0
Last updated
2026-10-30
Active installs
2,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Show any RSS or Atom feed as a clean list or accessible slider with a widget, a block or a shortcode. Cached, secure and lightweight. — by Fahad Mahmood

What to do

  1. Update to the latest version (4.0.0). Anything older than 3.0.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get rss-feed-widget --field=version shows what you run; wp plugin update rss-feed-widget updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2025-69349 · published 2026-01-06

Missing authorization check in RSS Feed Widget (3.0.2 and older)

Affected
3.0.2 and older
Fixed in
3.0.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Fahad Mahmood RSS Feed Widget rss-feed-widget allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects RSS Feed Widget: from n/a through <= 3.0.2.

NVD CVE-2025-69349Patchstack advisory

medium 4.8 CVE-2024-9835 · published 2024-11-12

Reflected cross-site scripting (XSS) in RSS Feed Widget (older than 3.0.1)

Affected
older than 3.0.1
Fixed in
3.0.1
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The RSS Feed Widget WordPress plugin before 3.0.1 does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attribute, which could lead to Reflected Cross-Site Scripting in old web browsers

NVD CVE-2024-9835WPScan advisory

medium 5.9 CVE-2024-9836 · published 2024-11-12

Stored cross-site scripting (XSS) in RSS Feed Widget (older than 3.0.0)

Affected
older than 3.0.0
Fixed in
3.0.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The RSS Feed Widget WordPress plugin before 3.0.0 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

NVD CVE-2024-9836WPScan advisory

medium 5.4 CVE-2024-10057 · published 2024-10-18

Stored cross-site scripting (XSS) in RSS Feed Widget (2.9.9 and older)

Affected
2.9.9 and older
Fixed in
3.0.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The RSS Feed Widget plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's rfw-youtube-videos shortcode in all versions up to, and including, 2.9.9 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-10057Wordfence advisoryCode change (fix)wordpress.org

medium 5.9 CVE-2024-32690 · published 2024-04-22

Stored cross-site scripting (XSS) in RSS Feed Widget (2.9.7 and older)

Affected
2.9.7 and older
Fixed in
2.9.8
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Fahad Mahmood RSS Feed Widget allows Stored XSS.This issue affects RSS Feed Widget: from n/a through 2.9.7.

NVD CVE-2024-32690Patchstack advisory

medium 6.1 CVE-2020-24314 · published 2020-08-26

Reflected cross-site scripting (XSS) in RSS Feed Widget (2.7.9 and older)

Affected
2.7.9 and older
Fixed in
2.8.1 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

Fahad Mahmood RSS Feed Widget Plugin v2.7.9 and lower does not sanitize the value of the "t" GET parameter before echoing it back out inside an input tag. This results in a reflected XSS vulnerability that attackers can exploit with a specially crafted URL.

NVD CVE-2020-24314wordpress.orgzeroaptitude.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
RSS Feed Widget vulnerability status badge
<a href="https://laskyr.com/plugins/rss-feed-widget"><img src="https://laskyr.com/plugins/rss-feed-widget/badge.svg" alt="RSS Feed Widget vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit