Skip to content
Laskyr

Plugins · rsfirewall · data as of 2026-11-04

Is RSFirewall! safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.49)

As of 2026-11-04. 3 issues are on record for older versions; version 1.1.46 or newer fixes all of them that state a fix.

Latest version
1.1.49
Last updated
2026-11-02
Active installs
4,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.4+

Based on the success of the most popular firewall for Joomla!, RSFirewall! is now available to protect your WordPress website as well. — by RSJoomla!

What to do

  1. Update to the latest version (1.1.49). Anything older than 1.1.46 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get rsfirewall --field=version shows what you run; wp plugin update rsfirewall updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-25341 · published 2026-03-25

Stored cross-site scripting (XSS) in RSFirewall! (1.1.45 and older)

Affected
1.1.45 and older
Fixed in
1.1.46
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in RSJoomla! RSFirewall! rsfirewall allows Stored XSS.This issue affects RSFirewall!: from n/a through <= 1.1.45.

NVD CVE-2026-25341Patchstack advisory

medium 4.9 CVE-2025-7518 · published 2025-07-12

Path traversal / file read in RSFirewall! (1.1.42 and older)

Affected
1.1.42 and older
Fixed in
unknown
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The RSFirewall! plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 1.1.42 via the get_local_filename() function. This makes it possible for authenticated attackers, with Administrator-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information.

NVD CVE-2025-7518Wordfence advisoryCode change (fix)

critical 9.8 CVE-2021-4226 · published 2022-12-15

Security issue in RSFirewall! (older than 1.1.25)

Affected
older than 1.1.25
Fixed in
1.1.25
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

RSFirewall tries to identify the original IP address by looking at different HTTP headers. A bypass is possible due to the way it is implemented.

NVD CVE-2021-4226WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
RSFirewall! vulnerability status badge
<a href="https://laskyr.com/plugins/rsfirewall"><img src="https://laskyr.com/plugins/rsfirewall/badge.svg" alt="RSFirewall! vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit