Skip to content
Laskyr

Plugins · rps-include-content · data as of 2026-11-04

Is RPS Include Content safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.3)

As of 2026-11-04. 2 issues are on record for older versions; version 1.2.3 or newer fixes all of them that state a fix.

Latest version
1.2.3
Last updated
2026-04-27
Active installs
700+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11

Makes it easy to pull content from one post or page and place it on another using a simple shortcode, even in a multisite environment. — by redpixelstudios

What to do

  1. Update to the latest version (1.2.3). Anything older than 1.2.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get rps-include-content --field=version shows what you run; wp plugin update rps-include-content updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-39639 · published 2026-04-08

Missing authorization check in RPS Include Content (1.2.2 and older)

Affected
1.2.2 and older
Fixed in
1.2.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in redpixelstudios RPS Include Content rps-include-content allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects RPS Include Content: from n/a through <= 1.2.2.

NVD CVE-2026-39639Patchstack advisory

medium 6.5 CVE-2025-31093 · published 2025-03-28

Cross-site scripting (XSS) in RPS Include Content (1.2.1 and older)

Affected
1.2.1 and older
Fixed in
1.2.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in redpixelstudios RPS Include Content rps-include-content allows DOM-Based XSS.This issue affects RPS Include Content: from n/a through <= 1.2.1.

NVD CVE-2025-31093Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
RPS Include Content vulnerability status badge
<a href="https://laskyr.com/plugins/rps-include-content"><img src="https://laskyr.com/plugins/rps-include-content/badge.svg" alt="RPS Include Content vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit