Plugins · rpb-chessboard · data as of 2026-11-04
Is RPB Chessboard safe? Known vulnerabilities and latest version
- Latest version
- 8.1.7
- Last updated
- 2026-09-25
- Active installs
- 1,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.2+
This plugin allows you to typeset and display chess diagrams and PGN-encoded chess games. — by yo35
What to do
- Update to the latest version (8.1.7). Anything older than 8.1.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get rpb-chessboard --field=version shows what you run; wp plugin update rpb-chessboard updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-13042 · published 2026-07-16
Stored cross-site scripting (XSS) in RPB Chessboard (8.1.2 and older)
- Affected
- 8.1.2 and older
- Fixed in
- 8.1.3 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The RPB Chessboard plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Comment Content in all versions up to, and including, 8.1.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. WordPress's save-time kses sanitization does not mitigate this issue because the crafted payload uses only kses-allowed tags and attributes (such as an <a> element with title and href), and the dangerous attribute-breaking HTML is synthesized entirely at render time by the plugin's own comment_text filter.
NVD CVE-2026-13042Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-09-25 — latest release on wordpress.org (8.1.7).
- 2026-07-16 — Stored cross-site scripting (XSS) disclosed (CVE-2026-13042), fixed in 8.1.3.
Get an email when RPB Chessboard has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for RPB Chessboard (rpb-chessboard) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/rpb-chessboard (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/rpb-chessboard"><img src="https://laskyr.com/plugins/rpb-chessboard/badge.svg" alt="RPB Chessboard vulnerability status"></a>