Skip to content
Laskyr

Plugins · royal-backup-reset · data as of 2026-11-04

Is Royal WordPress Backup, Restore & Migration Pl… safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.27)

As of 2026-11-04. 1 issue is on record for older versions; version 1.0.17 or newer fixes all of them that state a fix.

Latest version
1.0.27
Last updated
2026-06-08
Active installs
30,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

WordPress backup plugin to create full website backups and restore them easily. Built in migration to easily migrate your website, smart pre-update ba … — by WP Royal

What to do

  1. Update to the latest version (1.0.27). Anything older than 1.0.17 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get royal-backup-reset --field=version shows what you run; wp plugin update royal-backup-reset updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.1 CVE-2026-4305 · published 2026-04-10

Reflected cross-site scripting (XSS) in Royal WordPress Backup, Restore & Migration Pl… (1.0.16 and older)

Affected
1.0.16 and older
Fixed in
1.0.17 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Royal WordPress Backup & Restore Plugin plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'wpr_pending_template' parameter in all versions up to, and including, 1.0.16 due to insufficient input validation. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick an administrator into performing an action such as clicking on a link.

NVD CVE-2026-4305Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Royal WordPress Backup, Restore & Migration Pl… vulnerability status badge
<a href="https://laskyr.com/plugins/royal-backup-reset"><img src="https://laskyr.com/plugins/royal-backup-reset/badge.svg" alt="Royal WordPress Backup, Restore & Migration Pl… vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit